Using appveyor.yml all branches do not build

allen.thurman's Avatar

allen.thurman

16 Jul, 2019 06:40 PM

Hello all,

The way I understood it, appveyor builds ALL branches unless you specify it not to explicitly (either in the UI or the appveyor.yml) I am working with a project that has the appveyor.yml in the root of the repo. When I do a build it does not seem to use my yml file. Under the Custom configuration .yml file name section, I set the project to use --> \appveyor.yml. Can't figure out what is missing

  1. Support Staff 1 Posted by Owen McDonnell on 16 Jul, 2019 06:53 PM

    Owen McDonnell's Avatar

    No need to name the file in Custom Configuration field. If it is named appveyor.yml it will be picked up automatically.

  2. 2 Posted by allen.thurman on 16 Jul, 2019 08:17 PM

    allen.thurman's Avatar

    Hi Thx for reply. Cleared that box. Did not seem to work. It builds as if following the ui and not the appveyor.yml. I can tell because I set the verbosity to detailed in the appveyor.yml but it still builds minimal (according to the console output)

  3. Support Staff 3 Posted by Owen McDonnell on 16 Jul, 2019 10:09 PM

    Owen McDonnell's Avatar

    Can you send a link to the build.

  4. 4 Posted by allen.thurman on 16 Jul, 2019 10:50 PM

    allen.thurman's Avatar

    https://ci.appveyor.com/project/althurman/jenkinstest/settings

    not sure if that is it. I just started using appveyor today

  5. Support Staff 5 Posted by Owen McDonnell on 17 Jul, 2019 04:30 AM

    Owen McDonnell's Avatar

    Two things I noticed...
    First, not all your branches have an appveyor.yml config file. If it is not detected on the branch you're building UI settings will be used.
    Second, and probably more importantly, I believe your config file is being used but you have the verbosity: key on the root indentation level (i.e. it is not part of the build: node), and so is being ignored.

  6. 6 Posted by allen.thurman on 17 Jul, 2019 01:05 PM

    allen.thurman's Avatar

    Got it... Removed the old branches and made new branches off of master. Also updated the yml (see attached). Still no luck on this. I'm starting to think there is some setting in the appveyor web app that I am missing. Still looks like its just doing the automatic UI builds Console output below:

    Build started
    git clone -q --branch=master https://github.com/althurman/JenkinsTest C:\projects\jenkinstest
    msbuild "C:\projects\jenkinstest\ListFilesBySize.sln" /verbosity:minimal /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"
    Microsoft (R) Build Engine version 16.1.76+g14b0a930a7 for .NET Framework
    Copyright (C) Microsoft Corporation. All rights reserved.
      ListFilesBySize -> C:\projects\jenkinstest\ListFilesBySize\bin\Debug\ListFilesBySize.exe
    Discovering tests...OK
    Build success

  7. 7 Posted by allen.thurman on 17 Jul, 2019 01:27 PM

    allen.thurman's Avatar

    Also i notice in the events that it says my master branch was skipped because "skip branches without appveyor.xml" is checked

    My master does indeed have the appveyor.xml so still not sure if its syntax or something with the vm that appveyor is running the build on

  8. Support Staff 8 Posted by Owen McDonnell on 17 Jul, 2019 03:25 PM

    Owen McDonnell's Avatar

    You still have the verbosity: key indented wrong in the last config file.

    But its a moot point since you have added this repo as a generic git repo (not as a github repo) and generic git repos can not take advantage of config files.

    Please re-add the repo as a github one and you'll find it behaves much more as you expect.

  9. 9 Posted by allen.thurman on 17 Jul, 2019 04:47 PM

    allen.thurman's Avatar

    Yes!! creating a new project and adding the repo as github seemed to do the trick. Thanks alot!!!

  10. Support Staff 10 Posted by Owen McDonnell on 17 Jul, 2019 05:35 PM

    Owen McDonnell's Avatar

    No problem.

  11. Owen McDonnell closed this discussion on 17 Jul, 2019 05:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac