Compiling applications in appveyor

abdealikothari's Avatar

abdealikothari

06 Jul, 2015 04:31 PM

Hi,

I was recently trying to install dbus, gobject introspection and espeak to our appveyor build in coala.
I tried compiling dbus from source and kept getting errors regarding nmake not being found. So, I ran "SetEnv.cmd" for v7.1 and then cmake was unable to find my c compiler.

Here is the build : https://ci.appveyor.com/project/sils1297/coala/build/1.0.1020

Could you help me figure out what to do to fix this ?

  1. Support Staff 1 Posted by Feodor Fitsner on 06 Jul, 2015 07:11 PM

    Feodor Fitsner's Avatar

    I see you depend on VS 2015? I moved your account to a new environment.

  2. 2 Posted by abdealikothari on 14 Jul, 2015 07:59 AM

    abdealikothari's Avatar

    I was able to use pre compiled binaries thank fully, so I didn't need this

    Close this issue please :) and thanks !

  3. 3 Posted by abdealikothari on 17 Jul, 2015 02:39 AM

    abdealikothari's Avatar

    Can you please undo the earlier thing ? It seems to be breaking something - https://ci.appveyor.com/project/AbdealiJK/coala

  4. Support Staff 4 Posted by Feodor Fitsner on 17 Jul, 2015 03:07 AM

    Feodor Fitsner's Avatar

    I think nothing should be undoed there. It's not environment - you just need to provide appveyor.yml with correct build commands. Without that it's trying to find Visual Studio solution files to build. You can ask the guys from this project https://ci.appveyor.com/project/sils1297/coala/build/1.0.1020 to export their settings into YML.

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac