Upgrading to Visual Studio 2019 breaks build

Janos Turanszki's Avatar

Janos Turanszki

23 Jul, 2019 07:47 AM

I have upgraded my project to use Visual Studio 2019, previously it was using 2017 version. On my PC, the project builds correctly, as it was converted using "retarget solution" option. But it breaks in Appveyor with the following message:

The project file "WickedEngine\WickedEngine_SHARED.vcxitems" is in the ".vcproj" file format, which MSBuild no longer supports. Please convert the project by opening it in the Visual Studio IDE or running the conversion tool, or use MSBuild 3.5 or earlier to build it.

The project is hosted on GitHub: https://github.com/turanszkij/WickedEngine
And thre breaking build: https://ci.appveyor.com/project/turanszkij/wickedengine/build/job/sadoomk2431gt7uu

Please let me know if oyu can help with this.

Kind regards,

  1. 1 Posted by Janos Turanszki on 23 Jul, 2019 10:15 AM

    Janos Turanszki's Avatar

    I've found a thread that looks like it could be related, but I am not using Nuget packages, so this doesn't apply: https://help.appveyor.com/discussions/problems/1239-how-to-get-more-logs-for-exception-has-been-thrown-by-the-target-of-an-invocation-errors#comment_35592708

  2. 2 Posted by Janos Turanszki on 23 Jul, 2019 09:05 PM

    Janos Turanszki's Avatar

    I don't understand why it wants to build the vcxitems project that it mentions, it is a shared files project that doesn't participate in the build. I tried randomly making some changes in project files and solution that trigger a build and lets me check, but it always fails (but only on Appveyor). It is really annoying. I will switch back to VS 2017 build and wait for a fix.

    Here is a link to a failed build job: https://ci.appveyor.com/project/turanszkij/wickedengine/builds/26172910/job/0ltjcn9i0oj8pj0m

  3. 3 Posted by Janos Turanszki on 23 Jul, 2019 09:59 PM

    Janos Turanszki's Avatar

    Switching to Visual Studio 2019 Preview version in the yml and rebuilding doesn't trigger this error, but the build fails somewhere else:

    C:\Program Files (x86)\Microsoft Visual Studio\2019\Preview\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets(2817,7): error MSB4057: The target "CreateManifestResourceNames" does not exist in the project. [C:\projects\wickedengine\WickedEngine\WickedEngine_UWP.vcxproj]

    Link to the failed job with VS 2019 preview: https://ci.appveyor.com/project/turanszkij/wickedengine/build/job/xhvqqm4lv2w3l6m0

  4. 4 Posted by Owen McDonnell on 23 Jul, 2019 10:02 PM

    Owen McDonnell's Avatar

    I cloned your repo and tried using devenv \upgrade command to no avail.

    What do you mean by "doesn't participate in the build"? On your local build, what happens if you remove the vcxitems project files?

  5. 5 Posted by Janos Turanszki on 23 Jul, 2019 10:52 PM

    Janos Turanszki's Avatar

    The vcxitems project doesn't contain any build information, just .h and .cpp files, that will be built by an other project that references it, either WickedEngine_Windows.vcxproj or WickedEngine_UWP.vcxproj. So it doesn't make sense to remove this file. Did you try building the repo locally? Because I can build locally, but not with appveyor.
    Thanks for looking into this.

  6. 6 Posted by Owen McDonnell on 23 Jul, 2019 11:41 PM

    Owen McDonnell's Avatar

    Can you RDP to build worker and see if you can build the project following the same steps you do on your local machine.

  7. 7 Posted by Janos Turanszki on 31 Aug, 2019 07:23 PM

    Janos Turanszki's Avatar

    Hi, I've tried to RDP into a build worker (sorry for taking so long), but I can build the project just fine there. I tried opening Visual Studio 2019, and doing a "Rebuild Solution". I also tried opening Developer command prompt for Visual Studio 2019 and entering msbuild WickedEngine.sln, seems to build fine.

    However, appveyor build still gives me the error ".vcproj file format" like in the aboce posts, so I think it must be an appveyor specific issue. What is appveyor doing when trying to build my project?

  8. 8 Posted by Janos Turanszki on 18 Sep, 2019 11:02 PM

    Janos Turanszki's Avatar

    Is there any update on this? I am still looking to upgrade to VS 2019, but this issue with appveyor build system is currently blocking me.


  9. 9 Posted by Owen McDonnell on 19 Sep, 2019 03:54 AM

    Owen McDonnell's Avatar

    Sorry for the delay on this, it got buried under some other issues.

    Can you try to remove the build: section of your config and add a build_script: section with the following

      - msbuild "C:\projects\wickedengine\WickedEngine.sln" /m /verbosity:minimal /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"

    Let us know if that still returns this error.

  10. 10 Posted by Janos Turanszki on 19 Sep, 2019 07:06 PM

    Janos Turanszki's Avatar

    Hi Owen,

    Thanks a lot for the support and no worries! I have tried your suggestion, and confirm that it works well. I am happy with this workaround. However, I would be still interested in going back to the standard solution, so please let me know if the Appveyor team implements a fix for my problem.

    Best regards,

  11. 11 Posted by Owen McDonnell on 20 Sep, 2019 04:28 PM

    Owen McDonnell's Avatar

    We'll definitely be looking into it. I'll update here with findings when we have them.

  12. Feodor Fitsner closed this discussion on 03 Apr, 2020 06:44 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac