Using nuget restore

jonathan's Avatar

jonathan

23 Apr, 2014 08:54 AM

Hi

I run nuget restore before each of my builds which pulls packages down from nuget and out private myget feed.

This morning all of my builds are failing with a nuget operation timeout

If i test the same process on my machine in the office all works just fine.

Any ideas ?

Regards

Jonathan

  1. 1 Posted by steve on 03 Jun, 2014 02:06 PM

    steve's Avatar

    hi
    I'm just trying out appVeyor and getting the same
    We have a private nuget feed, so at first thebuild just failed
    then I added the feed creds, and the source (via settings > install > ps) and nuget restore via build > before build
    It seems to get through the restore, but then hangs
    no detail from teh console, but I imagine its the nuget restore, prompting for creds?
    all works locally and on a team city server

    Any ideas of how to get any more info?

  2. Support Staff 2 Posted by Feodor Fitsner on 03 Jun, 2014 04:53 PM

    Feodor Fitsner's Avatar

    Yep, most probably it asks for credentials.

    What commands have you used to add custom source with credentials? We have some recommendations here: http://www.appveyor.com/docs/nuget#restore-private-feed

  3. 3 Posted by steve on 03 Jun, 2014 09:53 PM

    steve's Avatar

    yep - found and followed them, so I have:
    nuget sources add -Name MyAccountFeed -Source https://www.myget.org/F/MyFeedUrl -UserName %nuget_user% -Password %nuget_password%

  4. 4 Posted by stevebaker2001 on 03 Jun, 2014 10:02 PM

    stevebaker2001's Avatar

    just to add, with that, if I add "nuget restore" as a powershell before build step, it just hangs

    If I dont have that setup, it fails the build when trying to package restore. we have this setup in a nuget.targets file:
    C:\projects\Project.nuget\nuget.targets(43,9): error MSB3073: The command ""C:\projects\Project.nuget\nuget.exe" install "C:\projects\Project\MyProject\packages.config" -source "https://nuget.org/api/v2/;https://www.myget.org/f/myfeed" -o "C:\projects\Project\packages"" exited with code 1. [C:\projects\Project\MyProject.csproj]

    at least for a migration period, we'll need to keep our packages on myget, so any help would be great

  5. Support Staff 5 Posted by Feodor Fitsner on 04 Jun, 2014 04:27 PM

    Feodor Fitsner's Avatar

    Hi Steve,

    Take a look at this thread: http://help.appveyor.com/discussions/problems/381-install-hangs

    This is how-to from a customer who managed to solve the issue with credentials. Hope that helps. Let me know if you have any questions.

  6. 6 Posted by stevebaker2001 on 05 Jun, 2014 07:11 PM

    stevebaker2001's Avatar

    Hi - took a look and with nuget verbose figured it out
    I had added the feed with:
    nuget sources add -Name MyFeedName with the name of the feed matching what we have in our nuget.targets
    changing it to use the feed url as the name as well solved it:

    nuget sources add -Name https://www.myget.org/F/myPrivateFeed

    all working now - win!

  7. Support Staff 7 Posted by Feodor Fitsner on 05 Jun, 2014 07:22 PM

    Feodor Fitsner's Avatar

    Great, thanks for the update! It's worth adding to "NuGet" article in our docs. I'm going to re-visit all recent reports related to NuGet to collect gotchas.

  8. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:44 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

 

22 Aug, 2019 08:13 PM
21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 05:56 AM