Problem with vcpkg (wrong version on appveyor?)

Igor Chorązewicz's Avatar

Igor Chorązewicz

06 Aug, 2019 07:09 AM

Recently my build on appveyor started to fail: https://ci.appveyor.com/project/pmem/libpmemobj-cpp/builds/26470193
(see attached log_1.txt). Following instruction in the warning: "Warning: Different source is available for vcpkg (2018.11.23 -> 2019.7.18). Use .\bootstrap-vcpkg.bat to update." I tried to run bootrstrap-vcpkg.bat but this resulted compilation error of vcpkg. I suspected that this might be an issue with mismatch between installed vcpkg and sources (as the warning suggests).

'vcpkg version' gave following output:
Vcpkg package management program version 2018.11.23-nohash

while 'git describe --tags' gave this:
2019.06-213-g8522c799

Should I manually update vcpkg (running git pull, \bootstrap-vcpkg.bat and vcpkg update) in my appveyor.yml?

  1. Support Staff 1 Posted by Owen McDonnell on 06 Aug, 2019 02:47 PM

    Owen McDonnell's Avatar

    Can you go to the last successful build and hit RE-BUILD COMMIT button, and if that fails switch to Previous version of whatever build image you are using, and then let us know the results.

  2. 2 Posted by Igor Chorązewic... on 08 Aug, 2019 08:38 AM

    Igor Chorązewicz's Avatar

    After clicking RE-BUILD COMMIT the build failed. However, switching to previous version (Previous Visual Studio 2015) fixed the build.

  3. Support Staff 3 Posted by Owen McDonnell on 08 Aug, 2019 03:06 PM

    Owen McDonnell's Avatar

    There was an image update recently which included a newer vcpkg version. It seems to be detecting previous version.
    Can you try invalidating/repopulating your cache.

  4. 4 Posted by Igor Chorążewic... on 08 Aug, 2019 03:57 PM

    Igor Chorążewicz's Avatar

    Actually the only thing which was in cache was: c:\tools\vcpkg\installed

    Removing the cache did not solve the issue.Stepping into C:\tools\vcpkg and running vcpkg version still returns old version.

  5. Support Staff 5 Posted by Owen McDonnell on 08 Aug, 2019 07:55 PM

    Owen McDonnell's Avatar

    Can you point me to the build in which you stepped into that folder and ran vcpkg version. When i tried i got the updated version.

  6. 6 Posted by Igor Chorązewic... on 09 Aug, 2019 09:12 AM

    Igor Chorązewicz's Avatar
  7. 7 Posted by Igor Chorązewic... on 09 Aug, 2019 09:17 AM

    Igor Chorązewicz's Avatar

    I also got version 2018.11.23-nohash when running `vcpkg version` but
    `git describe --tags`
    returns 2019.06-213-g8522c799

  8. Support Staff 8 Posted by Owen McDonnell on 09 Aug, 2019 03:25 PM

    Owen McDonnell's Avatar

    Sorry, i didn't realize myself at the time that the build i pointed to was showing older version of vcpkg. I've created an issue for that here.
    Are you able to use Visual studio 2017 image for your build?

  9. Support Staff 9 Posted by Owen McDonnell on 09 Aug, 2019 10:14 PM

    Owen McDonnell's Avatar

    Also, my colleague posted a workaround in that issue.

    install:
    - powershell iex ((new-object net.webclient).DownloadString('https://raw.githubusercontent.com/appveyor/build-images/master/scripts/Windows/install_vcpkg.ps1'))
    
  10. 10 Posted by Shmuel H. on 18 Aug, 2019 07:37 AM

    Shmuel H.'s Avatar

    We also have encountered the same problem. Using Visual Studio 2017 solves the problem; however, it is not the desired solution.

  11. 11 Posted by Chorazewicz, Ig... on 18 Aug, 2019 07:37 AM

    Chorazewicz, Igor's Avatar

    I'm out of office till 02/09/2019

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • log_1.txt 84.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac