cannot build project with opencv

Johann Jacobsohn's Avatar

Johann Jacobsohn

13 Jul, 2015 08:26 AM

I cannot build a project that depends on opencv, I get the error

Found OpenCV Windows Pack but it has not binaries compatible with your
  configuration.

and wasn't able to resolve it. To get the bottom of this I cloned https://ci.appveyor.com/project/JoakimSoderberg/catcierge, which passes the build, and tried to build it myself (https://ci.appveyor.com/project/jjacobsohn/catcierge), but I get the same error again.

How can the same project fail and pass depending on the account?

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Jul, 2015 05:14 PM

    Feodor Fitsner's Avatar

    Nice observation, thanks.

    Your jjacobsohn account runs on a new environment where build workers have Visual Studio 2015 installed. JoakimSoderberg account still runs on Azure where workers don't have VS 2015.

    There is a difference:

    Your account:

    -- Building for: Visual Studio 14 2015
    

    Their account:

    -- Building for: Visual Studio 12 2013
    

    The question - is there any way to force it building for VS 2013?

  2. 2 Posted by Johann Jacobsoh... on 14 Jul, 2015 03:05 PM

    Johann Jacobsohn's Avatar

    Setting the os-Property in the appveyor.yml file to unstable seems to fix the issue, but I don't think that's a permanent solution (?).

  3. Support Staff 3 Posted by Feodor Fitsner on 14 Jul, 2015 04:41 PM

    Feodor Fitsner's Avatar

    Yes, you just switched to an image without Visual Studio 2015. But VS 2015 is going to be released pretty soon and many developers will have it installed along with VS 2013. I don't believe that build can't be forced to use VS 2013 instead of using the most recent VS found. Have you tried contacting the author of that library?

  4. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 Mar, 2019 06:34 AM
26 Mar, 2019 06:27 AM
25 Mar, 2019 09:12 PM
25 Mar, 2019 06:34 PM
25 Mar, 2019 06:20 AM

 

24 Mar, 2019 06:52 PM
24 Mar, 2019 05:26 PM
24 Mar, 2019 03:07 AM
22 Mar, 2019 02:20 PM
22 Mar, 2019 11:00 AM
22 Mar, 2019 02:51 AM