Default -depth=50 instead of the whole commit history

filip's Avatar

filip

13 Jul, 2015 12:18 PM

Three days ago, our Git repo was building fine: https://ci.appveyor.com/project/gius/def/build/0.1.0-PullRequest.37%2B72%20(Build%2050)

Today, we accepted a pull request and suddenly we cannot build our repo anymore: https://ci.appveyor.com/project/gius/def/build/1.0.51

Note line 2 in both of the URLs. We didn't change any settings; in fact, the value for Git clone depth is empty, which means it should use the default value (the whole commit history). We are able to set a different numerical value for Git clone depth, but as soon as we leave it empty, it defaults to -depth=50. Our project cannot be built with depth of 50 and we do not want to put the INT_MAX value in the settings field. Does anyone else have this problem?

Our project build history URL is https://ci.appveyor.com/project/gius/def/history

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Jul, 2015 04:02 PM

    Feodor Fitsner's Avatar

    Will fix that later today.

    - Feodor

  2. 2 Posted by dave on 13 Jul, 2015 06:37 PM

    dave's Avatar

    Did some other stuff change with the default clone command? I'm also having issues building a repo that worked fine last week. My last succesful build had this:

    git clone -q --branch=master git://github.com/daveaglick/daveaglick.git C:\projects\daveaglick

    But now the clone looks like this:

    git clone -q --depth=50 --branch=master https://github.com/daveaglick/daveaglick.git C:\projects\daveaglick

  3. Support Staff 3 Posted by Feodor Fitsner on 13 Jul, 2015 06:44 PM

    Feodor Fitsner's Avatar

    Protocol changed from git to https as it adds security (though I don't think this could be an issue). Other than that nothing changed besides depth. You've been running on a new environment since June 27.

  4. 4 Posted by dave on 13 Jul, 2015 06:50 PM

    dave's Avatar

    Thanks - I also wouldn't think the protocol change would make a difference. Just notice it and was wondering if anything else changed.

    I run some git commands in my build script (specifically, I check out the "gh-pages" branch) and was getting confusing errors about the branch not existing (though it does). I suspect that if it was created prior to the current depth of 50, that might be the culprit.

    I'll sit tight until the fix for depth is in and try it again. Thanks for the quick response.

  5. 5 Posted by filip on 13 Jul, 2015 06:50 PM

    filip's Avatar

    Thanks, Feodor!

  6. Support Staff 6 Posted by Feodor Fitsner on 14 Jul, 2015 02:44 AM

    Feodor Fitsner's Avatar

    OK, the fix has been deployed.

  7. 7 Posted by filip on 14 Jul, 2015 11:50 AM

    filip's Avatar

    Thank you very much, Feodor! Default depth value now works fine, but now AppVeyor cannot recognize Entity Framework references. Is that a bug?
    https://ci.appveyor.com/project/gius/def/build/0.2.0-unstable.73+73%20(Build%2059)

  8. Support Staff 8 Posted by Feodor Fitsner on 14 Jul, 2015 01:16 PM

    Feodor Fitsner's Avatar

    Might be NuGet.org availability hiccups. Use cache to reduce dependency on that: http://www.appveyor.com/docs/nuget#dealing-with-intermittent-nuget-org-issues

    - Feodor

  9. 9 Posted by dave on 14 Jul, 2015 01:50 PM

    dave's Avatar

    FYI - fixing the depth resolved my own issue. Once again, thanks!

  10. 10 Posted by filip on 14 Jul, 2015 02:38 PM

    filip's Avatar

    I tried to re-run the build after a few hours and it seems to have fixed itself (or someone else at AppVeyor fixed it). :) Thanks again! Closing this thread.

  11. filip closed this discussion on 14 Jul, 2015 02:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 Mar, 2019 06:34 AM
26 Mar, 2019 06:27 AM
25 Mar, 2019 09:12 PM
25 Mar, 2019 06:34 PM
25 Mar, 2019 06:20 AM

 

24 Mar, 2019 06:52 PM
24 Mar, 2019 05:26 PM
24 Mar, 2019 03:07 AM
22 Mar, 2019 02:20 PM
22 Mar, 2019 11:00 AM
22 Mar, 2019 02:51 AM