anaconda upload is not working

dynaryu's Avatar


30 Aug, 2019 05:17 AM


I can not figure out why anaconda upload is not working:
anaconda -t %BINSTAR_TOKEN% upload %BUILT_PACKAGE% -u dynaryu
usage: anaconda [-h] [--disable-ssl-warnings] [--show-traceback] [-v] [-q]
                [-V] [-t TOKEN] [-s SITE]
anaconda: error: argument : invalid choice: 'C:\\Miniconda36-x64\\conda-bld\\win-64\\vaws-3.1-py36_1.tar.bz2' (choose from 'auth', 'label', 'channel', 'config', 'copy', 'download', 'groups', 'login', 'logout', 'move', 'notebook', 'package', 'remove', 'search', 'show', 'upload', 'whoami')

I tried moving '-u dynaryu' around still it does not work. Is it a conda problem? I don't have any problem in running from my windows machine.


  1. 1 Posted by dynaryu on 30 Aug, 2019 10:58 AM

    dynaryu's Avatar

    I figure out the error, as BINSTART_TOKEN is not recognized even it was defined the environment section. And If I put the real value of the TOKEN, it still does not upload the file to the anaconda channel.

  2. Support Staff 2 Posted by Ilya Finkelshte... on 30 Aug, 2019 05:01 PM

    Ilya Finkelshteyn's Avatar

    I've looked at your commits and builds history and I see that you tried a lot of things. I did not follow all iterations, but here are few things you should consider to make it work

    • If you use both Environment tab in UI and YAML file to set a variable, Environment tab in UI takes over. So decide on a single method to set this specific environment variable.

    • If you use Environment tab in UI, and paste already encrypted value in it, and then press "lock", it becomes double-encrypted, and therefore decoded into wrong value at the build time. Regardless if you press "lock" or not, you have to enter clear text value to Environment tab in UI.

    • if you use YAML, ensure you encrypted clear text value at It is critical to ensure that you are logged into dynaryu account (you see it on the upper left screen corner near AppVeyor logo). In case you encrypt value being logged under some different AppVeyor account, it will not be decoded during build which runs under dynaryu account.

    • Seems that anaconda writes its output to stdErr, which make custom PowerShell host AppVeyor runs in fail. So you only cmd for it (- ps: cmd /c will not help).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac