v141 build tools are missing from Visual Studio 2019 image

igagis's Avatar

igagis

02 Oct, 2019 01:03 PM

Hi,

I'm building my project with all versions of build tools v140,v141 and now I want to add v142.
For that I have to switch to Visual Studio 2019 image, but it appears the image does not contain v141 tools. Though it looks like v140 tools are there.

Also, that newer image does not contain Windows SDK 8.1 which is also needed to support Windows 7.

Could you add those to the image?

Here is the failed build:
https://ci.appveyor.com/project/igagis/papki/builds/27823277

  1. Support Staff 1 Posted by Feodor Fitsner on 02 Oct, 2019 06:49 PM

    Feodor Fitsner's Avatar

    We are going to install missing SDKs in the next update. Please watch this issue: https://github.com/appveyor/ci/issues/3071

    Will also look into installing v142 and SDK 8.1 as well:
    https://github.com/appveyor/ci/issues/3114
    https://github.com/appveyor/ci/issues/3113

  2. 2 Posted by igagis on 02 Oct, 2019 06:53 PM

    igagis's Avatar

    When do you expect next update will come out?

    Thanks!

  3. 3 Posted by igagis on 02 Oct, 2019 06:53 PM

    igagis's Avatar

    and you can close this discussion, I will track guthub issues

  4. igagis closed this discussion on 09 Oct, 2019 02:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac