Cygwin does not have Python 2.7 anymore since a few days

andreas.r.maier's Avatar

andreas.r.maier

12 Nov, 2019 10:28 AM

Hi, we are using both native Windows and CygWin with several Python versions. Since a few days, CygWin 64-bit does not seem to have a python2.7 command anymore.

Are you aware of any change that may have caused this?
Do we need to do anything different to make this work again?

Thanks
Andy

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Nov, 2019 05:08 AM

    Feodor Fitsner's Avatar

    Hi Andy,

    Indeed, cygwin has been re-installed during the last update: https://github.com/appveyor/ci/issues/3101

    Is there any component missing? This is the script we use to install cygwin on build image: https://github.com/appveyor/build-images/blob/master/scripts/Window...

  2. 2 Posted by andreas.r.maier on 13 Nov, 2019 01:42 PM

    andreas.r.maier's Avatar

    Hi Feodor. Yes, Python 2.7 is missing now and was there before the change. I issued a find command in our Appveyor runs on CygWin, and there is only /usr/bin/python3.6m.exe, but no other version of a python*.exe.

    Can Python 2.7 be re-established in CygWin?

  3. 3 Posted by andreas.r.maier on 13 Nov, 2019 01:48 PM

    andreas.r.maier's Avatar

    I checked the script you have linked above. There is nothing in the script that has changed to cause this. It must have changed in CygWin, then.

  4. 4 Posted by andreas.r.maier on 13 Nov, 2019 02:37 PM

    andreas.r.maier's Avatar

    I ran "cygcheck -c -d" and here is what it reports about packages with "python" in the package name:

    python 2.7.16-1
    python-pip-wheel 19.2.3-1
    python-setuptools-wheel 41.2.0-1
    python3 3.6.8-1
    python36 3.6.9-1

    That means that Python 2.7 is supposed to be installed.

    However, the only python programs in the PATH are:

    PATH=/usr/bin:/cygdrive/c/Windows/system32:/cygdrive/c/Windows:/cygdrive/c/ProgramData/chocolatey/bin

    /usr/bin/python3 /usr/bin/python3.6 /usr/bin/python3.6m.exe

    Previously, a python2.7 command was in that same PATH.

  5. Support Staff 5 Posted by Feodor Fitsner on 13 Nov, 2019 06:01 PM

    Feodor Fitsner's Avatar

    Looks like python2 should be explicitly installed to get Python 2.7. We'll modify image script, you can use the following workaround for now:

    cmd /c start /wait C:\cygwin\setup-x86.exe -qnNdO -R C:/cygwin -P python2
    
  6. 6 Posted by andreas.r.maier on 27 Nov, 2019 02:46 AM

    andreas.r.maier's Avatar

    Hi Feodor. I added the command to install python2 as you suggested, and that worked. This issue can be closed from my perspective.

    Thanks for the help!!

  7. Support Staff 7 Posted by Feodor Fitsner on 27 Nov, 2019 03:09 AM

    Feodor Fitsner's Avatar

    Cool, thanks for the update!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

05 Dec, 2019 09:12 PM
04 Dec, 2019 07:46 PM
04 Dec, 2019 12:01 AM
04 Dec, 2019 12:00 AM
03 Dec, 2019 11:00 PM