Visual Studio 2017 to Visual Studio 2019 image upgrade breaks build.

james_south's Avatar

james_south

21 Nov, 2019 02:45 AM

I don't really know where to start.

I've been experimenting with migrating our build from the Visual Studio 2017 image to the Visual Studio 2019 image and every time I workaround one issue another one arises.

https://ci.appveyor.com/project/six-labors/imagesharp/history

Notable issues.

  • Python34 not in path
  • Could not locate runner DLL for netcoreapp3.0; unsupported version of .NET Core
  • Installed Codecov version requires reducing to earlier version.

I would expect to be able to migrate from one environment to another without issue. Could you please guide me towards successfully configuring the build scripts.

Here is an example build with only minor changes to configuration to add a .NET Core 3.0 test run. This runs in some platforms but not others.

Always failing with the following output.

Command exited with code 2

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

07 Jul, 2020 06:21 PM
07 Jul, 2020 03:15 PM
05 Jul, 2020 02:33 AM
03 Jul, 2020 07:29 PM
03 Jul, 2020 03:53 AM

 

02 Jul, 2020 09:09 PM
02 Jul, 2020 03:24 PM
01 Jul, 2020 01:12 PM
30 Jun, 2020 04:26 PM
25 Jun, 2020 05:54 PM
24 Jun, 2020 08:11 AM