Deployments not triggering automatically.

byron's Avatar

byron

22 Jul, 2015 11:46 PM

We have been experiencing something new today (at least we think it was just today). Builds are are completing but deployments to an environment (agent) are not getting triggered automatically anymore. We can go in to "Deployments" for the project and "Update" to deploy using the most recent passing build, but it's manual. Thoughts or ideas?

  1. Support Staff 1 Posted by Feodor Fitsner on 22 Jul, 2015 11:59 PM

    Feodor Fitsner's Avatar

    Are you still experiencing that?

    As I understand to reproduce the issue I have to add "Environment" provider to appveyor.yml, correct?

  2. 2 Posted by byron on 23 Jul, 2015 12:14 AM

    byron's Avatar

    It is still happening. We are using the yml file and have the environment
    provider there.

  3. Support Staff 3 Posted by Feodor Fitsner on 23 Jul, 2015 12:20 AM

    Feodor Fitsner's Avatar

    I've just tested and it worked: https://ci.appveyor.com/project/FeodorFitsner/simple-web/build/1.0.36

    Do you see that in a build log?

    Deploying using Environment provider
    Started deployment to AAAAAA environment
    
  4. 4 Posted by camilo on 23 Jul, 2015 05:16 PM

    camilo's Avatar

    Hi Feodor, I'm working with Byron in this one and the build log is not showing any deploying message. It ends in build success message. Nothing else after that.

  5. Support Staff 5 Posted by Feodor Fitsner on 23 Jul, 2015 05:21 PM

    Feodor Fitsner's Avatar

    Hi Camilo,

    Make sure appveyor.yml contains deploy section (if you use appveyor.yml) or deployment step is set on UI under project settings.

  6. 6 Posted by camilo on 23 Jul, 2015 05:41 PM

    camilo's Avatar

    Feodor, I found the problem. We were using environment and deploy_script tag at the same time and for what I ready, appveyor takes only deploy_script.

    But other issue I'm seeing is the deploy environments doesn't move forward from this message: Wait remote deployment agents to start deployment...

  7. Support Staff 7 Posted by Feodor Fitsner on 23 Jul, 2015 05:47 PM

    Feodor Fitsner's Avatar

    Have you tried restarting Deployment Agent?

  8. 8 Posted by camilo on 23 Jul, 2015 05:54 PM

    camilo's Avatar

    Yes. I just restarted the service for deployment agent and now it deployed. Is this a normal behavior that I have to be restarting the deployment agent?

  9. Support Staff 9 Posted by Feodor Fitsner on 23 Jul, 2015 06:04 PM

    Feodor Fitsner's Avatar

    No, sometimes connection between agent and the cloud is broken, but we are working on improving reliability.

  10. 10 Posted by camilo on 23 Jul, 2015 06:26 PM

    camilo's Avatar

    Ok

  11. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac