Deployment isn't triggering

Trevor Sullivan's Avatar

Trevor Sullivan

23 Jul, 2015 07:02 PM

Hello,

I have a PowerShell project with a deploy.ps1 script and appveyor.yml, both in the root. The deploy.ps1 script is not getting executed, however.

Being a PowerShell script module, there is no "build" or "artifacts" to speak of. However, during the deploy phase, I would like to publish the PowerShell module to the PowerShell Gallery (powershellgallery.com), so that users can use Find-Module to locate it. I am using the Unstable AppVeyor OS image, which includes PowerShell 5.0 April 2015 Preview, which contains the PowerShellGet module that allows me to use the Publish-Module command to publish to the gallery.

I have tried many, many variations of the YAML file, and nothing seems to work. How do I make sure that deploy.ps1 is executed, even though I don't have a "build" or any "artifacts?"

Cheers,
Trevor Sullivan
Microsoft MVP: PowerShell

  1. Support Staff 1 Posted by Feodor Fitsner on 23 Jul, 2015 07:34 PM

    Feodor Fitsner's Avatar

    deploy.ps1 is to use along with Deployment Agent.

    Seems like you just need to call it directly like:

    deploy_script:
    - ps: .\deploy.ps1
    
  2. 2 Posted by Trevor Sullivan on 24 Jul, 2015 04:41 PM

    Trevor Sullivan's Avatar

    @Feodor: Thanks, that worked.

    Cheers,
    Trevor Sullivan
    Microsoft MVP: PowerShell

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Aug, 2019 11:06 PM
21 Aug, 2019 02:08 PM
21 Aug, 2019 01:37 PM
21 Aug, 2019 10:21 AM
21 Aug, 2019 09:10 AM

 

21 Aug, 2019 05:56 AM
21 Aug, 2019 03:08 AM
20 Aug, 2019 11:33 PM
20 Aug, 2019 08:07 PM
20 Aug, 2019 05:50 PM
20 Aug, 2019 12:35 PM