BYOC - Host Agent not working (errors and not responding to requests)

seanmeyer's Avatar

seanmeyer

05 Feb, 2020 07:41 AM

Hello,

I just setup a self hosted environment, using Docker on Windows Server 2019, and I'm having some problems. The environment is showing as offline, and I can't run the docker container. When I try to do docker run appveyor-byoc-windows, I get this output:

Reading worker metadata

Fetching Process worker metadata.

fail: Appveyor.BuildAgent.Service.AgentHostedService[0]

Error executing agent hosted service: One or more errors occurred. (Worker metadata does not contain AppveyorUrl.)

info: Microsoft.Hosting.Lifetime[0]

Application is shutting down...

Finished agent hosted service

I have no idea what I'm doing wrong. I followed the instructions at https://www.appveyor.com/docs/byoc/docker/ and there were no errors during setup. Am I missing some steps required to bring the docker build agent online?

  1. Support Staff 1 Posted by Feodor Fitsner on 05 Feb, 2020 02:21 PM

    Feodor Fitsner's Avatar

    Hi Sean,

    What is the name of account/cloud you are having problems with? Have you tried restarting Host Agent service?

  2. 2 Posted by seanmeyer on 05 Feb, 2020 03:32 PM

    seanmeyer's Avatar

    The account is named FinFolio, and the project is named FinFolio.Core. The cloud is called ARYA Docker. I've tried restarting the host agent service on the windows computer (not the docker). I also see some warnings and errors with this in the event log:

    Category: Appveyor.HostAgent.Services.HostAgentHubClientFactory
    EventId: 0
    Error fetching AppVeyor version via /api/version endpoint: The remote server returned an error: (404) Not Found.
    
    Category: Appveyor.HostAgent.AppHost
    EventId: 0
    Error registering Host Agent: Object reference not set to an instance of an object.
    
    Category: Appveyor.HostAgent.AppHost
    EventId: 0
    Ping callback has not received in 20 seconds: a9a727e9-0a73-4f81-b3b7-2c14429ad7cb
    
  3. Support Staff 3 Posted by Feodor Fitsner on 05 Feb, 2020 03:38 PM

    Feodor Fitsner's Avatar

    In the Registry under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Appveyor\HostAgent key could you please check that you have a correct authorization token there? If the token is correct try deleting Host Agent database in %PROGRAMDATA%\AppVeyor\HostAgent and restart the service again.

  4. 4 Posted by seanmeyer on 05 Feb, 2020 03:58 PM

    seanmeyer's Avatar

    Deleting the database fixed it! Thank you!

  5. Support Staff 5 Posted by Feodor Fitsner on 05 Feb, 2020 05:05 PM

    Feodor Fitsner's Avatar

    Great, thanks for the update!

  6. Feodor Fitsner closed this discussion on 06 Apr, 2020 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

07 Jul, 2020 06:21 PM
07 Jul, 2020 03:15 PM
05 Jul, 2020 02:33 AM
03 Jul, 2020 07:29 PM
03 Jul, 2020 03:53 AM

 

02 Jul, 2020 09:09 PM
02 Jul, 2020 03:24 PM
01 Jul, 2020 01:12 PM
30 Jun, 2020 04:26 PM
25 Jun, 2020 05:54 PM
24 Jun, 2020 08:11 AM