Build failures since a couple of days

luk.vermeulen's Avatar

luk.vermeulen

23 Feb, 2020 04:42 PM

Hi,

Since a couple of days I am experiencing build failures. I cannot imagine what's wrong, since the project builds correctly on my own machine. Can you have a look at https://ci.appveyor.com/project/lvermeulen/bitbucket-cloud-net please?

I have deleted all failing builds except the last one, which has the exact same build errors as the other failed builds.

Thanks in advance!

Luk

  1. Support Staff 1 Posted by Feodor Fitsner on 24 Feb, 2020 05:44 PM

    Feodor Fitsner's Avatar

    Hi Luk,

    Looks like switch statements (and maybe other C# 7+ features) causes those errors.

    What version of .NET Core do you use locally to build the project?

  2. Support Staff 2 Posted by Feodor Fitsner on 24 Feb, 2020 05:45 PM

    Feodor Fitsner's Avatar

    global.json is referencing 1.1.13: https://github.com/lvermeulen/Bitbucket.Cloud.Net/blob/8f17ccd3c8d2... - isn't it kinda old for switches with lambda?

  3. 3 Posted by luk.vermeulen on 24 Feb, 2020 07:47 PM

    luk.vermeulen's Avatar

    Indeed it is quite old. :-/

    I have updated global.json to sdk version 3.1.100, but now it's telling me "MSB4044: The "GetPackOutputItemsTask" task was not given a value for the required parameter "PackageVersion".", which is an error that I avoided in the past by including a global.json.

    Do you have any advice as to how to proceed?

    Thanks!

    Luk

  4. Support Staff 4 Posted by Feodor Fitsner on 24 Feb, 2020 08:46 PM

    Feodor Fitsner's Avatar

    Try adding PackageVersion element into project file: https://github.com/lvermeulen/Bitbucket.Cloud.Net/blob/master/src/B...

  5. 5 Posted by luk.vermeulen on 25 Feb, 2020 09:04 AM

    luk.vermeulen's Avatar

    I have tried adding <PackageVersion> to the csproj file, but I get the same result.

  6. Support Staff 6 Posted by Feodor Fitsner on 25 Feb, 2020 11:57 PM

    Feodor Fitsner's Avatar
  7. 7 Posted by luk.vermeulen on 26 Feb, 2020 07:35 AM

    luk.vermeulen's Avatar

    Thanks!!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac