mssql broken package situation

Hari Sekhon's Avatar

Hari Sekhon

09 Mar, 2020 10:24 AM

When trying to install packages there is a breakage around mssql-server:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 mssql-server : Depends: libsasl2-modules-gssapi-mit but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I believe this is caused by some mssql add-ons, so I've tried to sed the mssql repo out of /etc/apt/sources.list before installing any packages but it still happens, so I'm not sure if this is caused by a pre-existing pending package installation.

Here is the build:

https://ci.appveyor.com/project/HariSekhon/devops-python-tools/buil..., log is attached showing the error.

Is there a debug build of AppVeyor that I can reproduce this on, perhaps a docker image?

I had a check on dockerhub to see if there was anything similar:

docker run -ti --rm appveyor/build-image
Unable to find image 'appveyor/build-image:latest' locally
docker: Error response from daemon: manifest for appveyor/build-image:latest not found: manifest unknown: manifest unknown.

There is no documentation or Dockerfile so I'm just having a punt trying everything before contacting you:

docker run -ti --rm appveyor/build-images
Unable to find image 'appveyor/build-images:latest' locally
latest: Pulling from appveyor/build-images
ff3a5c916c92: Pull complete 
5820355806b9: Pull complete 
57406db1bb7d: Pull complete 
644e86f1b6ee: Pull complete 
68458ff9fba3: Pull complete 
134137d0fa75: Pull complete 
df2c6a409545: Pull complete 
c9637e7fb778: Pull complete 
172b3ee35f55: Pull complete 
Digest: sha256:bb3a73c35d64c30183cc8e0bf3595aa1385bc2ef9009c3950b702554f8f17b14
Status: Downloaded newer image for appveyor/build-images:latest
Error: Please define azure_client_id variable.
failed to resize tty, using default size
  1. Support Staff 1 Posted by Feodor Fitsner on 09 Mar, 2020 10:44 PM

    Feodor Fitsner's Avatar

    Maybe it's because AppVeyor image already has MS SQL Server pre-installed: https://www.appveyor.com/docs/linux-images-software/#databases?

    This is the script used to install SQL Server: https://github.com/appveyor/build-images/blob/master/scripts/Ubuntu...

  2. Feodor Fitsner closed this discussion on 10 May, 2020 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac