Vim(call):E739: Cannot create directory

Grégory Salvan's Avatar

Grégory Salvan

09 Apr, 2020 03:54 AM

Hi, I'm struggling to execute the testsuite for a vim plugin that fail to write directories and files.
The plugin is here https://gitlab.com/apieum/diantre

This is the interesting failing build copied in the attached file: (last version of vim errors are silenced)
https://ci.appveyor.com/project/apieum/diantre/build/job/leno1wsj4c4v5tai

I've added this line in appveyor.yml to set rights:
    ICACLS "C:\projects\diantre\autoload" /grant:r "appveyor:(F)" /C

Also I've tried with basckslash directory separator and got the exact same error.
I dig and read other cases with similar errors but couldn't find a solution.
Would you please help me.

  1. Support Staff 1 Posted by Feodor Fitsner on 09 Apr, 2020 05:39 PM

    Feodor Fitsner's Avatar

    What directory does it (process?) fail to write into?

  2. 2 Posted by Grégory Salvan on 10 Apr, 2020 05:33 AM

    Grégory Salvan's Avatar

    It fails to create directories inside the plugin at C:\projects\diantre\autoload

  3. 3 Posted by Grégory Salvan on 16 Apr, 2020 01:09 PM

    Grégory Salvan's Avatar

    I've found the reason:
    mkdir -p has a different behaviour on windows, if the directory exists it throws an error ^^'

  4. Support Staff 4 Posted by Feodor Fitsner on 16 Apr, 2020 04:29 PM

    Feodor Fitsner's Avatar

    Nice, thanks for the update!

  5. Feodor Fitsner closed this discussion on 16 Jun, 2020 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac