Support iojs 2.5.0, 3.0.0

justin's Avatar

justin

06 Aug, 2015 04:54 PM

When I try to use nodejs_version: "2.5.0" it fails. It seems like that version hasn't yet been added to whatever mechanism you are using to obtain it.

nodejs is now on version 3.0.0, it would be nice to get those versions available asap.

Also, what string should I use to always get the latest version of node? I would like to just do: nodejs_version: "iojs", which is what travis does.

  1. Support Staff 1 Posted by Feodor Fitsner on 06 Aug, 2015 05:55 PM

    Feodor Fitsner's Avatar

    That will be updated shortly.

    To get the latest io.js use '' (empty string) version.

  2. 2 Posted by justin on 06 Aug, 2015 06:02 PM

    justin's Avatar

    Ok, thanks.

  3. justin closed this discussion on 06 Aug, 2015 07:14 PM.

  4. justin re-opened this discussion on 28 Aug, 2015 05:01 PM

  5. 3 Posted by justin on 28 Aug, 2015 05:02 PM

    justin's Avatar

    The version has not been updated, I am now on 3.1.0 I am unable to run tests on the CI server without having this version. This is blocking me now.

    Why is there a limit on the version at all, why doesn't it just do any version specified? Which mechanism are you using to install node, so I can see which versions are supported and participate in that more actively?

  6. Support Staff 4 Posted by Feodor Fitsner on 28 Aug, 2015 10:04 PM

    Feodor Fitsner's Avatar

    We've just added io.js 3.1.0 and 3.2.0.

  7. 5 Posted by justin on 29 Aug, 2015 08:41 PM

    justin's Avatar

    I see it now, I'm unblocked. Thanks.

  8. justin closed this discussion on 29 Aug, 2015 08:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac