Error: GitHub authorization required when using GitHub App

constantine's Avatar

constantine

11 May, 2020 11:53 AM

Hi,
We have a public repo. We changed auth method to "Authorize as GitHub App", installed the app and granted needed permissions (see file attached).
Getting:
Error fetching YAML configuration file from the repository. Make sure AppVeyor is authorized to access your gitHub account: GitHub authorization required.

Here's the build:
https://ci.appveyor.com/project/Cloudinary/cloudinarydotnet/builds/32788726

Thank you!

  1. Support Staff 1 Posted by Feodor Fitsner on 11 May, 2020 04:46 PM

    Feodor Fitsner's Avatar

    Hi Constantine,

    On Account -> Authorizations page do "Revoke access" and then "Import existing installations". That should do the trick.

  2. 2 Posted by constantine on 11 May, 2020 05:45 PM

    constantine's Avatar

    Hi Feodor,

    There was no "Revoke access" button on that screen, so I just hit "Import existing installations" and it did work!

    Thank you for your help!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2020-05-11_at_14.50.33.png 117 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac