No space left on device

daniel11420's Avatar

daniel11420

14 May, 2020 08:30 PM

Hi! I'm making an Electron app and using electron-builder to build it.
I'm running a macos AppVeyor CI and near the end of the build I get the following error
⨯ Exit code: 1. Command failed: ln -s /Applications /Volumes/Frosty Desktop 1.0.0/Applications
ln: /Volumes/Frosty Desktop 1.0.0/Applications: No space left on device
ln: /Volumes/Frosty Desktop 1.0.0/Applications: No space left on device
I'm here to request a disk space increase. Although, this has worked before, but it's probably because of something I added.
Thanks!

Some links:
My project: https://ci.appveyor.com/project/daniel11420/frostydesktop
The specific build that is failing: https://ci.appveyor.com/project/daniel11420/frostydesktop/builds/32884514

  1. Support Staff 1 Posted by Feodor Fitsner on 17 May, 2020 08:09 PM

    Feodor Fitsner's Avatar

    We'll look into that during the next macOS image update (we are working on it right now). I've created a new issue to track: https://github.com/appveyor/ci/issues/3436

    For now, you may try to workaround that by deleting something unnecessary.

  2. 2 Posted by daniel11420 on 17 May, 2020 10:49 PM

    daniel11420's Avatar

    There is nothing unnecesarry???

  3. Support Staff 3 Posted by Feodor Fitsner on 18 May, 2020 07:26 PM

    Feodor Fitsner's Avatar

    Actually, there should be around 60 GB available on macOS images. It doesn't look like that error comes because there is no disk space on VM disk itself.

  4. 4 Posted by daniel11420 on 19 May, 2020 04:41 AM

    daniel11420's Avatar

    hm, thats weird. what should i do then? appveyor CI worked fine before

  5. Support Staff 5 Posted by Feodor Fitsner on 19 May, 2020 04:48 AM

    Feodor Fitsner's Avatar

    MacOS images haven't been updated for a while. When was the last successful build?

  6. 6 Posted by daniel11420 on 20 May, 2020 11:22 PM

    daniel11420's Avatar
  7. 7 Posted by daniel11420 on 20 May, 2020 11:29 PM

    daniel11420's Avatar

    So turns out my thing was on macOS-Mojave for some reason, but I changed it to macOS and it still didn't work.

  8. Support Staff 8 Posted by Feodor Fitsner on 20 May, 2020 11:31 PM

    Feodor Fitsner's Avatar

    Try re-building that las successful commit?

  9. 9 Posted by daniel11420 on 21 May, 2020 04:45 AM

    daniel11420's Avatar

    hm, it worked

  10. 10 Posted by daniel11420 on 09 Jun, 2020 03:48 PM

    daniel11420's Avatar

    Hello? It's still happening;;;;

  11. Support Staff 11 Posted by Feodor Fitsner on 09 Jun, 2020 04:55 PM

    Feodor Fitsner's Avatar

    The fact that rebuilt of the last successful commit is successful hints that it's not environment changes, but some changes to the code that caused that error.

    Moreover, with the recent macOS images update there is now around 80 GB of free space for your builds: https://ci.appveyor.com/project/appveyor-tests/macos#L86 which should be enough, right?

  12. Feodor Fitsner closed this discussion on 09 Aug, 2020 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac