UDP multicast doesn't work anymore on Ubuntu

thomasv1000's Avatar

thomasv1000

18 May, 2020 11:39 PM

I noticed that one of my tests started to fail on Ubuntu: https://ci.appveyor.com/project/VlingoNetOwner/vlingo-net-wire/build/job/4mqpbluh6jn2pb4e/tests. After some investigation it seems that binding to network interface eth0, is an issue. I'm unable to multicast any UDP packets on that interface.

Quick look on "Previous Ubuntu" and everything seems to work ok https://ci.appveyor.com/project/VlingoNetOwner/vlingo-net-wire/build/job/rjvgfahujohmfy3q/tests

Seems like this is only the issue on Ubuntu because all other images work like a charm.https://ci.appveyor.com/project/VlingoNetOwner/vlingo-net-wire/builds/32964824

What has changes on this image that this UT doesn't work anymore ?

  1. Support Staff 1 Posted by Feodor Fitsner on 18 May, 2020 11:44 PM

    Feodor Fitsner's Avatar

    We configured Ubuntu VMs to use DHCP. Could it be the problem?

  2. Support Staff 2 Posted by Feodor Fitsner on 18 May, 2020 11:47 PM

    Feodor Fitsner's Avatar

    Also, we tighten firewall on VMs - try loosing/disabling it to see if that helps.

  3. 3 Posted by thomasv1000 on 19 May, 2020 04:01 AM

    thomasv1000's Avatar

    I’m not sure about DHCP. I’ll try disabling firewall. Do “ sudo ufw disable” is enough or there is a different way ?

    Any guidance on how to do it would be great

  4. 4 Posted by thomasv1000 on 19 May, 2020 05:03 PM

    thomasv1000's Avatar

    It is a firewall issue.
    Disabling the firewall worked well https://ci.appveyor.com/project/VlingoNetOwner/vlingo-net-wire/builds/32984184/tests

    How do I disable it just for a specific image ?

  5. 5 Posted by thomasv1000 on 19 May, 2020 05:15 PM

    thomasv1000's Avatar

    Problem solved. Thanks for a suggestion of firewall which was effectively the problem.

  6. Support Staff 6 Posted by Feodor Fitsner on 19 May, 2020 05:17 PM

    Feodor Fitsner's Avatar

    Cool, thanks for the update!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac