C / CXX compiler identification is unknown

codetympan's Avatar

codetympan

20 May, 2020 04:10 PM

Hi,
We've migrated our project from Mercurial to Git.
The pipeline on the Mercurial project works well, but in the new git project's pipeline, CMake 3.6.3 can't find the C / CXX compilers of Visual Studio 2010.
Old project working fine : https://bitbucket.org/TYMPAN/code_tympan/src/default/appveyor.yml
New project with the trouble :https://bitbucket.org/jripolles/code_tympan_git/src/master/appveyor.yml

I can't figure out the reason why CMake can't find the C/ CXX compilers now.
I've tried configuring the image Visual Studio 2015 in the settings, then setting a variable image in appveyor.yml, but it always fail.

Could you give us the right configuration to have the pipeline works again ?

Thanks in advance for your help.
Jean.

  1. Support Staff 1 Posted by Feodor Fitsner on 20 May, 2020 04:15 PM

    Feodor Fitsner's Avatar

    Hi Jean,

    Configure image: Visual Studio 2015 in appveyor.yml. If there is a YAML in the repo then UI settings are mostly ignored. Let me know if that worked.

  2. 2 Posted by codetympan on 25 May, 2020 07:56 AM

    codetympan's Avatar

    Hi Feodor,
    It worked, thank you very much !

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • log_appveyor_20200520.txt 19 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac