Nuget Publish failed due to /p:GeneratePackageOnBuild=false override added even though my csproj as GeneratePackageOnBuild

mvadu's Avatar

mvadu

28 May, 2020 04:08 AM

Hello, I am using the AppVeyor to publish to Nuget. It always worked until now. I am doing some housekeeping and moved few properties to build.props. I have <GeneratePackageOnBuild>true</GeneratePackageOnBuild> set on my main project in its csproj. Yet I see AppVeyor passing /p:GeneratePackageOnBuild=false, and finally NuGet publish is failing since there is no nuget package generated. Please help.

Deploying using NuGet provider
No artifacts were uploaded. Make sure you have specified correct artifacts filter.
Build success
  1. 1 Posted by mvadu on 28 May, 2020 04:09 AM

    mvadu's Avatar
  2. Support Staff 2 Posted by Feodor Fitsner on 28 May, 2020 04:18 PM

    Feodor Fitsner's Avatar

    Remove publish_nuget: true from your appveyor.yml (or disable corresponding option on "Build" tab of project settings if you don't use YAML).

  3. 3 Posted by mvadu on 29 May, 2020 02:36 AM

    mvadu's Avatar

    Thank you Feodor, I tried updating yml. Now I can see its generating the package, but the final deployment part still failed. I had to manually add an artifact to pick up *.nupkg. This was not needed few days ago when my project had both .NET Framework as well as netstandard projects. Once its made as multi platform project this issue started. Did I miss anything?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac