Compiled .exe disappear

Swerik's Avatar

Swerik

29 May, 2020 07:31 AM

I wrote a .jar file that compiles c++ files to .exe and I run that in my build. I can see that this goes through successfully because g++ shows no errors and on my local machine it also works fine. But on the AppVeyor machine the exe files aren't there after compiling.
I'll attach the log so you can see for yourself (I cancelled the build after the interesting part was over).

They should be compiled to Project-Folder/out/cpp/*.exe and the folder gets created and g++ has no errors, but the files still don't exist.

  1. Support Staff 1 Posted by Feodor Fitsner on 29 May, 2020 04:58 PM

    Feodor Fitsner's Avatar

    If there were no errors this could only mean compiled files were placed into some different location. AppVeyor is not modifying/altering files/output in any way.

    Try playing with folder names, enabling detailed log.

  2. 2 Posted by Swerik on 03 Jun, 2020 01:18 PM

    Swerik's Avatar

    I now wrote the compiler from scratch in c# instead of java and tested it locally a lot. It works locally but it doesn't on appveor

    No errors but still no files, its so weird

  3. 3 Posted by Swerik on 03 Jun, 2020 01:27 PM

    Swerik's Avatar

    Weird Okay im onto something, thanks

    I get Exit Code 1 from g++ eventhough there is no error

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • log.txt 7.82 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

02 Jul, 2020 03:24 PM
01 Jul, 2020 08:32 PM
01 Jul, 2020 01:12 PM
30 Jun, 2020 04:26 PM
25 Jun, 2020 05:54 PM