brew update lets Build exit with code 1 on macOS

Ingo's Avatar

Ingo

29 May, 2020 03:20 PM

Hello everyone,

My previously working build config for macos stops now very early while testing and working on the issue of failed artifacts collection. During the install step it exits with Build exited with code 1 during or right after brew update. Same happens during brew install which runs the update step implicitly beforehand.

One of the failing build jobs is: https://ci.appveyor.com/project/SASfit/sasfit/builds/33198741
and its appveyor.yaml: https://github.com/SASfit/SASfit/blob/648d79b39dccc27ccdd829e32d50d...

Not sure, am I missing something?
Thanks for any help or hints!

Best wishes
Ingo

  1. Support Staff 1 Posted by Feodor Fitsner on 29 May, 2020 04:46 PM

    Feodor Fitsner's Avatar

    Hi Ingo,

    We are going to fix that in the next macOS update: https://github.com/appveyor/ci/issues/3455

    For now please use the following workaround:

    HOMEBREW_NO_AUTO_UPDATE=1 brew install ...
    

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

02 Jul, 2020 03:24 PM
01 Jul, 2020 08:32 PM
01 Jul, 2020 01:12 PM
30 Jun, 2020 04:26 PM
25 Jun, 2020 05:54 PM