Cant call Set-AppveyorBuildVariable anymore

Matthias's Avatar

Matthias

30 May, 2020 02:45 PM

Hi,
for whatever reasons a Set-AppveyorBuildVariable command which has worked in previous builds is returning an 404 error now:
```yaml
install:
  # installing necessary tools by PSDepend bootstrap (dependencies.psd1)
  - ps: |
      . .\build.ps1 -Bootstrap
      . .\build.ps1 Init
      Set-AppveyorBuildVariable BuildOutput $env:BHBuildOutput
      Set-AppveyorBuildVariable ProjectName $env:BHProjectName
```

Error is
Exception calling "SetBuildVariable" with "2" argument(s): "The remote server returned an error: (404) Not Found."

What is the issue of AppVeyor server returning 404 now?

  1. Support Staff 1 Posted by Feodor Fitsner on 30 May, 2020 02:50 PM

    Feodor Fitsner's Avatar

    Could you drop a link to a broken build please? What was the last good build it worked?

  2. Support Staff 2 Posted by Feodor Fitsner on 30 May, 2020 05:44 PM

    Feodor Fitsner's Avatar
  3. 3 Posted by Matthias Flesch... on 31 May, 2020 09:51 AM

    Matthias Fleschütz's Avatar

    Hi Feodor,
    hm...strange, I checked it again and again...

    Here it has worked 8 days ago, e.g. on
    https://ci.appveyor.com/project/blindzero/connect-ms365/builds/3307...
    The build itself failed, because second job didn't have BuildOutputs, but first job completed as it should.

    Running Install scripts  
    . .\build.ps1 -Bootstrap
    . .\build.ps1 Init
    Set-AppveyorBuildVariable BuildOutput $env:BHBuildOutput  
    Set-AppveyorBuildVariable ProjectName $env:BHProjectName  
    <pre><code>
    Starting yesterday it didn&#39;t work out any more on any of the builds.
    Sure, I changed other parts of the yml but first not in the part which is failing.
    Then I tried escaping the far to $($env:BHBuildOutput) which doesn&#39;t change.
    The actual yml can be found here:
    https://github.com/blindzero/Connect-MS365/blob/feature/appveyor/appveyor.yml
    
    I would have expected that some later part may fail as I tried to implement artifact publishing and later downloading in second job, but it is not coming that far.
    
    Best,
    M.</code>
    </pre>
    
  4. Support Staff 4 Posted by Feodor Fitsner on 01 Jun, 2020 05:58 PM

    Feodor Fitsner's Avatar

    OK, could you please try rebuilding that successful commit?

  5. 5 Posted by Matthias on 10 Jun, 2020 01:25 PM

    Matthias's Avatar

    I used the file from last working commit and it worked with it.
    Now I dived into it a little further and I played around with all tiny little changes possibly affected my install: part.
    I couldn't find any.
    using $($env:VAR) instead of $env:VAR in my ps: - no problem
    removing / inserting empty linebreak after install: block before next yaml block - no problem
    having an indent instead of just a empty linebreak at the end of install:block - no problem

    I will now insert all other changes but it seems that some other part in the yaml outside of the real install: causes the error but console is misleading.

  6. 6 Posted by Matthias on 14 Jun, 2020 09:38 AM

    Matthias's Avatar

    Hi,
    honestly I don't know what might have been the issue. After inserting all changes again in small portions it works now although the yml is the same now...

    Can be closed & Thanks,
    M.

  7. Support Staff 7 Posted by Feodor Fitsner on 15 Jun, 2020 04:39 AM

    Feodor Fitsner's Avatar

    OK, glad it's working again (though not-knowing the source of the issue is worrying :).

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac