`gem install bundler` takes forever and lets build time out (JRuby)

Tobias Pfeiffer's Avatar

Tobias Pfeiffer

09 Aug, 2015 04:10 PM

I tried setting up my project `shoes4` on appveyor but the build times out lots of times on `gem install bundler`.

I know that this problem [happened before](http://help.appveyor.com/discussions/problems/691-ruby-gem-install-bundler-hanging) and the solution was to pre install bundler. However, I'm using (and have to) use JRuby which is not pre installed - so I have to install it myself.

I tried it with both JRuby 1.7.21 and JRuby 9.0.0.0 but that doesn't seem to influence it. Sometimes it passes, sometimes it fails due to timeout on `gem install bundler`.

It'd be great to have JRuby preinstalled with bundler preinstalled (1.7. branch and 9.0.0.0 branch - but that might be too much to ask). Are there other options?

For reference:

* [a working build[(https://ci.appveyor.com/project/PragTob/shoes4/build/1.0.7) - that one took a whopping 30 minutes for a simple `gem install bundler` as it can be seen in [the logs](https://ci.appveyor.com/api/buildjobs/v7984e6pkg10ewdv/log)
* [a failing build](https://ci.appveyor.com/project/PragTob/shoes4/build/1.0.8) - gem install bundler never finishes

It'd be great if this could be worked out (many people on Windows use JRuby and the JRuby project itself also wants to start using AppVeyor as they sometimes have problems with some windows support).

Cheers + thanks for providing a free for open source Windows CI <3
Tobi

  1. 1 Posted by Tobias Pfeiffer on 09 Aug, 2015 04:18 PM

    Tobias Pfeiffer's Avatar

    Oh yes, for further reference the branch being build currently is the [appveyor branch on my fork of shoes4](https://github.com/PragTob/shoes4/tree/appveyor) if you want to look at the configuration file (basically downloads and installs JRuby then install bundler, does a `bundle install` and then runs the specs)

  2. Support Staff 2 Posted by Feodor Fitsner on 10 Aug, 2015 05:29 PM

    Feodor Fitsner's Avatar

    Hi Tobi,

    So, basically, JRuby should be installed on build worker machines? Could it be conflicting with "regular" Ruby installation?

  3. Support Staff 3 Posted by Feodor Fitsner on 10 Aug, 2015 05:32 PM

    Feodor Fitsner's Avatar

    Never mind, I've got it.

  4. 4 Posted by Tobias Pfeiffer on 10 Aug, 2015 05:43 PM

    Tobias Pfeiffer's Avatar

    Hi there,

    that would be one solution and that would certainly be great - so then I
    wouldn't have to set JRuby up myself.

    Overall, it'd still be interesting to find out why `gem install bundler`
    takes forever and fix that root cause :)

    On 10.08.2015 19:32, Feodor Fitsner wrote:

  5. Support Staff 5 Posted by Feodor Fitsner on 10 Aug, 2015 05:48 PM

    Feodor Fitsner's Avatar

    I'd love to find the answer too, frankly :) as it takes long on regular Ruby too (not all versions).

  6. Support Staff 6 Posted by Feodor Fitsner on 14 Aug, 2015 06:14 PM

    Feodor Fitsner's Avatar

    JRuby has been deployed to build workers: https://github.com/appveyor/ci/issues/356

  7. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

16 Jul, 2019 04:51 AM
15 Jul, 2019 06:33 PM
15 Jul, 2019 06:09 PM
15 Jul, 2019 05:53 PM
15 Jul, 2019 05:46 PM