CI fails with memory issues on some VMs/Projects

Slavey Karadzhov's Avatar

Slavey Karadzhov

18 Jun, 2020 10:11 AM

We have two projects (VMs) that are testing the same git commit and are using the same appveyor file. One of them fails constantly and the other never fails: see this https://ci.appveyor.com/project/slaff/sming-sb483/builds/33576184 and that https://ci.appveyor.com/project/slaff/sming/builds/33576182. The failure that we got is

AR /c/projects/sming-sb483/Sming/out/Host/debug/lib/clib-bearssl-esp8266.a
C:\MinGW\msys\1.0\bin\make.exe: *** couldn't commit memory for cygwin heap, Win32 error 0

We tried hard to figure out the issue (https://github.com/SmingHub/Sming/pull/2086) but the problem is still present. Can it be that the failing project is having somehow a VM with less memory while the one that is succeeding is having more RAM? Or are the underlying host systems different and causing the issue?

We are really out of ideas as to what can be the issue and hope that you can help us.

  1. Support Staff 1 Posted by Feodor Fitsner on 19 Jun, 2020 01:51 AM

    Feodor Fitsner's Avatar

    Checked the log. I can confirm that both builds were running on the same Visual Studio 2015 image in the same environment. Try running on Visual Studio 2019 image?

  2. 2 Posted by Slavey Karadzho... on 19 Jun, 2020 09:31 AM

    Slavey Karadzhov's Avatar

    Thanks for the hint Feodor. We tried it (https://github.com/SmingHub/Sming/pull/2086/commits/d131aee99223088...) but unfortunately the build is still failing on one of the systems and succeeding on the other:

    https://ci.appveyor.com/project/slaff/sming-sb483/builds/33618320 Fails
    https://ci.appveyor.com/project/slaff/sming/builds/33618316 Success

    Absolutely the same appveyor.yml file, same git commit, same source code.

  3. Support Staff 3 Posted by Feodor Fitsner on 19 Jun, 2020 04:37 PM

    Feodor Fitsner's Avatar

    It's not the same commit though.

    Here you are testing a "normal" branch commit: https://ci.appveyor.com/project/slaff/sming/builds/33618075?fullLog...
    while here you are testing virtual PR commit saying "what if I merge that "normal" commit to a base 'develop' branch": https://ci.appveyor.com/project/slaff/sming-sb483/builds/33618320 which is actually very cool. It says that either develop branch is broken or a merge of develop and appveyor-out-of-memory is.

  4. Feodor Fitsner closed this discussion on 19 Aug, 2020 09:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac