Mac building broken for no apparent reason.

AyanamiRei0's Avatar


07 Jul, 2020 04:18 AM

Hello there, I'm trying to build a program it has Windows, Mac and Linux builds however all of a sudden the Mac builds fail even though nothing has changed all I get is this error.

Running "before_build" scripts
.ci/macos/ line 3: pip3: command not found
.ci/macos/ line 4: qtsass: command not found
Command exited with code 127
Build failed

the command installs qtsass for those style sheets. please note this worked fine before but now it just breaks.


  1. Support Staff 1 Posted by Feodor Fitsner on 07 Jul, 2020 02:31 PM

    Feodor Fitsner's Avatar

    No macOS images have been updated recently - it must be some external dependencies you are pulling during the build.
    Could you drop a link to a build please?

  2. 2 Posted by AyanamiRei0 on 07 Jul, 2020 06:21 PM

    AyanamiRei0's Avatar the only thing I changed from the original creator was the appveyor.yml for testing Mac builds.

    Previously it was exactly the same as a fully working cloned repository like so.

  3. 3 Posted by AyanamiRei0 on 08 Jul, 2020 06:15 PM

    AyanamiRei0's Avatar

    Hello can I get some help please nothing has changed but it doesn't work when it's a exact clone of someone elses and that worked fine.

    I want to repeat nothing has changed between mine and theirs

  4. AyanamiRei0 closed this discussion on 09 Jul, 2020 10:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac