windows build broken without any change [vcpkg not found]

L4ZZA's Avatar

L4ZZA

08 Jul, 2020 02:42 PM

I haven't build my project for 5 days and now every build fails even with the same changes of the latest working build

It seems like something went wrong with vcpkg as the only project not building is my tests project as it doesn't find the boost library

  1. Support Staff 1 Posted by Feodor Fitsner on 08 Jul, 2020 06:04 PM

    Feodor Fitsner's Avatar

    There was VS 2019 image update on July 3 which, of course, bumped vcpkg: https://www.appveyor.com/updates/2020/07/03/

    Try disabling vcpkg cache in your build.

  2. 2 Posted by L4ZZA on 09 Jul, 2020 08:16 AM

    L4ZZA's Avatar

    I did and it still doesn't work.. the VcpkgTripletSelection defaults to x64-windows instead of using the one specified inside the project x64-windows-static
    https://ci.appveyor.com/project/L4ZZA/pyro/builds/33986729

    The workaround I found was to explicitly add vcpkg include dir $(VcpkgInstalledDir)x64-windows-static/debug/include to debug and $(VcpkgInstalledDir)x64-windows-static/include to release. Not ideal.
    https://ci.appveyor.com/project/L4ZZA/pyro/builds/33986703

  3. 3 Posted by L4ZZA on 09 Jul, 2020 08:35 AM

    L4ZZA's Avatar

    I also tried to use image: Previous Visual Studio 2019 and it works without hardcoding the additional includes here.
    Is it possible that this has to do with the most recent vcpkg release?
    It's pretty weird that it still works on my machine after updating vpkg..

  4. 4 Posted by L4ZZA on 13 Jul, 2020 08:58 AM

    L4ZZA's Avatar

    any update on this? :)

  5. Support Staff 5 Posted by Feodor Fitsner on 13 Jul, 2020 10:33 PM

    Feodor Fitsner's Avatar

    Honestly, I'm not an expert in C++/vcpkg, but perhaps vcpkg team could help if you submit an issue there.

  6. 6 Posted by L4ZZA on 14 Jul, 2020 10:55 AM

    L4ZZA's Avatar

    well, the problem is not with vcpkg in general, but with the image update.

    Vcpkg works on my machine as expected, even after updating to its latest released version 2020.06.

    On AppVeyor though, the build fails using Visual Studio 2019, but succeeds using Previous Visual Studio 2019 without changing anything else in the yaml file and this ever since the latest image update.

    I can honestly only see a problem that has to do with the OS image here.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac