Issue with concurrent process for the generated file

laurent.bernabe's Avatar

laurent.bernabe

13 Jul, 2020 06:21 PM

My build is nearly perfect, but I get a strange issue :

Creating setup files
   Updating icons (SETUP.EXE)
   Compressing: C:\projects\chesspgnreviser\release\ChessPgnReviser.exe   (0.0.0.0)
Error in C:\projects\chesspgnreviser\windows_build.iss: The process cannot access the file because it is being used by another process.
Compile aborted.
Command exited with code 2

I've joined the script and the complete log.

Maybe is it something related to the use of InnoSetup and the Deployment on Github on the same time ?

Regards

  1. 1 Posted by laurent.bernabe on 13 Jul, 2020 06:27 PM

    laurent.bernabe's Avatar

    Adding inno setup script

  2. Support Staff 2 Posted by Feodor Fitsner on 13 Jul, 2020 06:39 PM

    Feodor Fitsner's Avatar

    It's unclear from the build log which file exactly is locked.

    Anyway, your best course to fix that is to login via RDP to build VM and using sysinternals tools see who is locking that file. Hope that helps.

  3. 3 Posted by laurent.bernabe on 13 Jul, 2020 06:50 PM

    laurent.bernabe's Avatar

    Thank you, I'm going to check the build steps with it.
    Is there a documentation page about the available sysinternals tools ?

    Regards

  4. 4 Posted by laurent.bernabe on 13 Jul, 2020 08:17 PM

    laurent.bernabe's Avatar

    I've managed to connect by RDP to the VM, but I don't know which tool from the machine can help me see which process is locking the executable file.

  5. Support Staff 5 Posted by Feodor Fitsner on 13 Jul, 2020 10:30 PM

    Feodor Fitsner's Avatar

    You can download Process Explorer while in RDP: https://helpcenter.gsx.com/hc/en-us/articles/115015880627-How-to-Id...

  6. 6 Posted by laurent.bernabe on 14 Jul, 2020 07:49 AM

    laurent.bernabe's Avatar

    Thank you. I'm gonna try with it.

  7. 7 Posted by laurent.bernabe on 14 Jul, 2020 08:47 AM

    laurent.bernabe's Avatar

    I've downloaded the Process Explorer on the VM, but I did not have the time to search for the locking process. Because the system is halted as soon as Inno Setup build is started (line "iscc windows_build.iss" of the appveyor_v2.yml).

    And so I've lost the connection though I tried to block the RDP a second time. (See appveyor_v2.yml)

  8. 8 Posted by laurent.bernabe on 14 Jul, 2020 11:00 AM

    laurent.bernabe's Avatar

    Finally solved the issue : I needed to change directory when creating the setup file with InnoSetup (See before_deploy section).

    I've joined the final script

  9. laurent.bernabe closed this discussion on 14 Jul, 2020 11:01 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac