undesired MSYS2 installation with error on "vcpkg install <deps>"

DaftMat's Avatar

DaftMat

27 Jul, 2020 08:59 PM

while installing the vcpkg dependencies, a weird error started to pop 2 days ago. Actually, it says "Acquiring MSYS2" before installing the dependency, but then show some errors and the build fails from timeout after a while.

Here is a build showing what it looks like
https://ci.appveyor.com/project/DaftMat/daft-engine/builds/34331064

I found several materials on the internet but nothing change anything, and as it appeared without any reason on this build, I'm wondering if some last updates of MSYS2 or vcpkg are responsible for this mess.

  1. Support Staff 1 Posted by Feodor Fitsner on 27 Jul, 2020 11:21 PM

    Feodor Fitsner's Avatar

    I'm pretty sure it's either MSYS or vcpkg upstream changes as no AppVeyor images have been recently changed (updates history).

  2. 2 Posted by DaftMat on 28 Jul, 2020 12:12 AM

    DaftMat's Avatar

    Actually, I removed the lines that update vcpkg from the yml script, seems to work. You can close this issue I think unless not being able to update vcpkg from your machines is a problem.
    Thank you for the answer!

  3. DaftMat closed this discussion on 28 Jul, 2020 12:15 AM.

  4. DaftMat re-opened this discussion on 29 Jul, 2020 05:06 PM

  5. DaftMat closed this discussion on 30 Jul, 2020 02:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac