Error installing AppVeyor agent on Windows 2008 R2

austin's Avatar

austin

13 Aug, 2020 01:58 AM

I'm trying to install the AppVeyor Deployment Agent (latest version 6.3.2) onto a Windows 2008 R2 server and everything works until it tries to start the Service and it says:

Service 'AppVeyor Deployment Agent' (Appveyor.DeploymentAgent) failed to start. Verify that you have sufficient privileges to start system services.

I can see the service is registered, but it will not start. I tried rebooting the server and re-installing, but still no luck. I'm logged in as the Administrator on this machine.

I saw this thread which says Windows Server 2008 technically is not support, but it sounded like that person got it to work.

https://help.appveyor.com/discussions/problems/1503-deploy-error-after-appveyor-deploy-agent-update

Any ideas how to resolve this?

  1. Support Staff 1 Posted by Feodor Fitsner on 13 Aug, 2020 03:56 AM

    Feodor Fitsner's Avatar

    Are there any errors in "Application" and/or "AppVeyor" Windows event logs?

  2. 2 Posted by austin on 13 Aug, 2020 03:39 PM

    austin's Avatar

    Yes, thank you, I should have checked there first. It looks like it requires .NET Framework 4.6.2. I'll install that on the server and see if that resolves the issue.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2020-08-12_at_9.50.30_PM.png 114 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac