Previous Visual Studio 2017 stopped working (Python 3.6 & 3.7)

Rebecca Bilbro's Avatar

Rebecca Bilbro

18 Aug, 2020 09:41 PM

Sometime between August 6, 2020 and August 16, 2020 we began observing a persistent failure ("DLL load failed error") when running our tests with Python 3.6 and 3.7.

We have been using Appveyor to simulate testing on a Windows operating systems for several years and have experienced the same issues with Previous Visual Studio 2015 and Previous Visual Studio 2019.

Following the suggestion provided, we then reverted to using Previous Visual Studio 2017, which has worked up until recently, when it started hanging indefinitely for our Miniconda tests. We ended up removing Miniconda from our Appveyor test matrix after we could not find a resolution.

However, sometime in the last week, Previous Visual Studio 2017 also stopped running for our Python 3.6 and 3.7 tests as well, failing with "ImportError: DLL load failed: The specified module could not be found."

We have tried changing to Visual Studio 2017, Visual Studio 2019, and Previous Visual Studio 2019, but these images all now seem to make it about 85% of the way through our tests until hanging and eventually timing out (potentially because all of the VM resources have been consumed?).

Is it possible that there was a change to the Previous Visual Studio 2017 image after August 6 and before August 16 that could be causing the image to fail when installing Python dependencies?

Thank you very much for your attention, and thank you in advance for any assistance you can provide!

  1. Support Staff 1 Posted by Feodor Fitsner on 19 Aug, 2020 08:31 PM

    Feodor Fitsner's Avatar

    Hi Rebecca,

    Both VS 2017 and previous VS 2017 images haven't been recently changed. I believe it could be some upstream changes in python modules you use.

    Let me know if there's anything else we can do to help you with troubleshooting the issue.

  2. Feodor Fitsner closed this discussion on 19 Oct, 2020 09:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac