Unable to generate Newman html report

Karthik Kancharla's Avatar

Karthik Kancharla

08 Oct, 2020 07:47 AM

Hi Team,

Unable to generate Newman html report observed below error message

Command executed with exception: Γ£ö File export location: /newman

Expected: it should create newman folder and generated html report should be placed

Please find below build script
Install-Product node 14 x64
npm install -g --unicode=false newman
npm install -g --unicode=false newman-reporter-htmlextra
newman run .\Postman_Collections\Insight_TestAutomation.json -e .\Postman_Collections\Insights_Test_Environment.postman_environment.json -g .\Postman_Collections\Insights.postman_globals.json -r htmlextra -n 1 -k --disable-unicode

Please do needfull help

Thank you
Karthik Kancharla

  1. Support Staff 1 Posted by Feodor Fitsner on 09 Oct, 2020 02:19 AM

    Feodor Fitsner's Avatar

    Hi Karthik,

    Move Install-Product node 14 x64 to "Install script" on Environment tab and then switch "Build script" to Cmd. Let me know if that worked.

  2. 2 Posted by Karthik Kanchar... on 09 Oct, 2020 06:01 AM

    Karthik Kancharla's Avatar

    Hi Team,

    Solution worked partially. Able to get the success reponse as shown below
    ✔ HTMLEXTRA report created!
    ✔ File export location: /newman

    but the newman folder not created and html report not uploaded in the bit bucket repositry

    Please reolve this.

    Thanks and Regards,
    Karthik Kancharla

  3. Support Staff 3 Posted by Feodor Fitsner on 09 Oct, 2020 04:25 PM

    Feodor Fitsner's Avatar

    It looks like "newman" tool is exiting with non-zero exit code. Unfortunately, I don't have any experience with newman and can't tell what's wrong with your command, sorry.

    To speedup troubleshooting you may login to VM via RDP and try running the same command there. Hope that helps.

  4. Feodor Fitsner closed this discussion on 09 Dec, 2020 09:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac