Problem running Appveyor

Albert's Avatar

Albert

11 Nov, 2020 12:01 PM

Since yesterday we encounter problems running Appveyor for doxygen compilations. We get:
WARNING: You are using pip version 19.3.1; however, version 20.2.4 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
"[requires]
 libxml2/2.9.8@bincrafters/stable
 winflexbison/2.5.16@bincrafters/stable" | Out-File -Encoding ASCII -FilePath conanfile.txt
conan install . -g virtualrunenv --build missing
Traceback (most recent call last):
  File "C:\Python27\Scripts\conan-script.py", line 6, in <module>
    from pkg_resources import load_entry_point
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 3250, in <module>
    @_call_aside
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "c:\python27\lib\site-packages\pkg_resources\__init__.py", line 791, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (urllib3 1.26.0 (c:\python27\lib\site-packages), Requirement.parse('urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1'), set(['requests']))

Reference to build: https://ci.appveyor.com/project/doxygen/doxygen/builds/36251098

Any idea?

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Nov, 2020 05:58 PM

    Feodor Fitsner's Avatar

    Looking at the error pkg_resources.ContextualVersionConflict: (urllib3 1.26.0 I suspect there was a version bump in urllib3 - one of conan dependencies. Indeed, last successful build installs urllib-1.25.11 and the failing build installs urllib-1.26.0. Oh, and there is a newer version of conan 1.31.2 already released which fixes the issue with liburl3: https://github.com/conan-io/conan/releases/tag/1.31.2

  2. 2 Posted by Albert on 11 Nov, 2020 06:01 PM

    Albert's Avatar

    Thanks for te answer, does this mean that on the doxygen side something has to be done or on the Appveyor side?

  3. Support Staff 3 Posted by Feodor Fitsner on 11 Nov, 2020 06:02 PM

    Feodor Fitsner's Avatar

    I don't know. Anyway, the AppVeyor VM images haven't been changed - if there are overnight issues they are definitely "upstream" ones.

  4. 4 Posted by Albert on 11 Nov, 2020 06:12 PM

    Albert's Avatar

    OK thanks looks like we have to wait for our next doxygen build so that the newest version of conan can be used.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac