space in name of build cloud

sdarwin's Avatar


12 Nov, 2020 03:22 PM

Here are a couple issues I ran into with self-hosted appveyor, BYOC, Windows 2019, AWS.

  1. Installed docker agent on windows machine. It created a "Build Cloud" called "EC2AMAZ-OSSRDFH Docker". Great. Then on the Build Environment->Images->Add Image->Add Build Worker Image screen, there's a field for "Build cloud". If you try to enter "EC2AMAZ-OSSRDFH Docker" it says "Name can contain letters, numbers and dash (-)". A space in the name is not permitted. However, the name "EC2AMAZ-OSSRDFH Docker" had been automatically generated. Probably generated names should not include spaces?

  2. Due to the difficulty of installing "choco install -y python" in Docker, mentioned in another thread, tried to start from scratch "docker build" this image: . That succeeded. Python was installed. Then, something unexpected happened. Running a job with this new image, where the appveyor.yml file uses a command "xcopy", which is present on the image, and usually can be run, now it says "/opt/appveyor/server/ line 51: xcopy: command not found". To replicate: fresh docker build of windows-servercore-build-image.Dockerfile with no modifications. A basic appveyor file that has a section:

  - xcopy file1 file2
  1. 1 Posted by sdarwin on 13 Nov, 2020 02:22 PM

    sdarwin's Avatar

    Solved issue #2 (the xcopy problem), and it was coincidentally connected to issue #1 (space in build cloud name).

    So, when experimenting with the setting just mentioned Build Environment->Images->Add Image->Add Build Worker Image -> build cloud, this got set and unset during the testing. Finally at the end, it was left unspecified.
    When you don't specify the build cloud, it defaults to the main settings default, which is the Process cloud.

    So, builds were not running on the docker cloud, they had shifted to the Process cloud which lacks xcopy. Adding the build cloud name back is one way to solve it, of course another way is to adjust the build cloud setting elsewhere such as in the project, etc. So, it is fixed.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac