MSBuild: No certificate found with the supplied thumbprint after importing it.

andrewfehr's Avatar


28 Nov, 2020 07:51 PM

I am using appveyor to build an app with msbuild. It requires a certificate to be installed to the system. I have used to secure variables and powershell to import my pfx file into LocalMachine\Root. It seems like it imports correctly because it prints the thumbprint of the certificate. However, MSBuild complains that the certificate with that same thumbprint is not installed. Here is the link to my appveyor build:

  1. Support Staff 1 Posted by Feodor Fitsner on 30 Nov, 2020 01:42 AM

    Feodor Fitsner's Avatar

    Looks like a similar issue which is not yet resolved:

    Well, the only things I can suggest to try are:

    1. Use Visual Studio 2019 image, not a preview
    2. Try importing certificate to user store, not machine
    3. Connect to build VM via RDP and try building from IDE and command line while there. Check if cert is properly imported.
    4. Make sure you are able to build locally from a command line with the same commands as in build.

    Hope that helps.

  2. 2 Posted by andrewfehr on 30 Nov, 2020 10:27 PM

    andrewfehr's Avatar

    I thought I had tried importing it to the user store but I guess I hadn't. Importing to CurrentUser\My solved my problem. Thanks!

  3. andrewfehr closed this discussion on 30 Nov, 2020 10:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac