Nuget Connectivity Issues.

Wade Kallhoff's Avatar

Wade Kallhoff

11 Dec, 2020 12:59 AM

Build : https://ci.appveyor.com/project/AmberPharmacy/patient-portal

As of last night, at least two of my projects are running into an issue connecting to NuGet to restore packages:

  https://api.nuget.org/v3/index.json: Unable to load the service index for source https://api.nuget.org/v3/index.json.
  An error occurred while sending the request.
  The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
  The remote certificate is invalid according to the validation procedure.
Restoring NuGet package Autofac.Mvc5.4.0.2.
They used to be built under the Visual Studio 2017 environment but I switched to 2019 to try and fix this issue with no luck.

My build configuration has no reference to any lines mentioned in other posts that, once removed, should have fixed this problem.

Any thoughts?

  1. 1 Posted by Wade Kallhoff on 11 Dec, 2020 01:01 AM

    Wade Kallhoff's Avatar
  2. 2 Posted by Wade Kallhoff on 11 Dec, 2020 01:18 AM

    Wade Kallhoff's Avatar

    Turns out I was wrong and my appveyor.yml file did include

        hosts:
          api.nuget.org: 93.184.221.200
    

    Once I removed this, my builds worked again.

  3. Support Staff 3 Posted by Feodor Fitsner on 11 Dec, 2020 02:23 AM

    Feodor Fitsner's Avatar

    Yep, that was another form of that fix. Thanks for the update.

  4. Feodor Fitsner closed this discussion on 10 Feb, 2021 09:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac