CMake 3.13 or higher is required. You are running version 3.10.2

Xottab_DUTY's Avatar

Xottab_DUTY

21 Mar, 2021 04:03 PM

We are getting this error:
CMake Error at ... (cmake_minimum_required):
CMake 3.13 or higher is required. You are running version 3.10.2

However, documentation says that even Ubuntu 16.04 has CMake 3.19 installed and we are using Ubuntu 18.04.
Is it a mistake in the documentation or some servers didn't get updated CMake maybe?

The failing build: https://ci.appveyor.com/project/OpenXRay/xray-16/builds/38324604/jo...

  1. Support Staff 1 Posted by Feodor Fitsner on 22 Mar, 2021 05:46 PM

    Feodor Fitsner's Avatar

    I'm testing it on Ubuntu1804 image and there is CMake 3.19.1: https://ci.appveyor.com/project/FeodorFitsner/simple-console/builds...

    Maybe you are installing/updating CMake during the build?

  2. 2 Posted by Xottab_DUTY on 23 Mar, 2021 11:23 AM

    Xottab_DUTY's Avatar

    Thank you! Yes, we were installing CMake, the issue is fixed now.

  3. Xottab_DUTY closed this discussion on 07 Apr, 2021 07:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac