Nuget not downloading certain packages

mez613's Avatar

mez613

30 Aug, 2015 12:38 PM

A PR was made and kicked off this build.
The changes are simple, but include pulling down NUnit 2.6.4. For some reason it is not being downloaded.
(The error on MySql.Data doesn't bother me right now as it is not actually being used)

The log file is atached.

(As an aside, it seems that analyzer support is a little iffy - what am I missing?)

  1. Support Staff 1 Posted by Feodor Fitsner on 30 Aug, 2015 01:25 PM

    Feodor Fitsner's Avatar

    Are you getting this error all the time or just occasionally?

    - Feodor

  2. 2 Posted by mez613 on 31 Aug, 2015 07:57 AM

    mez613's Avatar

    In the past it happened once before (builds 1.0.11-14) but that was due to changing the physical location of projects.

    In this PR a new project was added, but previous builds have worked when projects where added. The only thing that stands out here is a new NuGet dependency was added, that isn't anywhere else in the solution

  3. Support Staff 3 Posted by Feodor Fitsner on 31 Aug, 2015 08:03 AM

    Feodor Fitsner's Avatar

    Have you tried doing "nuget restore" before the build?

    - Feodor

  4. 4 Posted by mez613 on 31 Aug, 2015 09:22 AM

    mez613's Avatar

    That was missing and fixed it. Thank you.

    Should I open another ticket that the analyzer can't be loaded?

    An instance of analyzer SwitchEnum.SwitchEnumAnalyzer cannot be created from C:\projects\myhome\packages\SwitchEnumAnalyzer.1.0.0.3\tools\analyzers\SwitchEnum.dll : Could not load file or assembly 'System.Collections.Immutable, Version=1.1.33.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified..

  5. Support Staff 5 Posted by Feodor Fitsner on 31 Aug, 2015 09:37 AM

    Feodor Fitsner's Avatar

    Well, yeah, if you think that issue is AppVeyor-specific.

    - Feodor

  6. mez613 closed this discussion on 31 Aug, 2015 09:41 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac