PR Build Error 'error: could not lock config file'...

Matt's Avatar


06 Apr, 2021 04:05 PM

I'm having an issue with building specifically pull requests:

Build started
error: could not lock config file %HOMEDRIVE%%HOMEPATH%/.gitconfig: No such file or directory
Command exited with code 255
Build failed

Building normal commits work without any issues. I verified the .gitconfig file exists for the proper user, permissions are correct and there is no lock file. This started after upgrading git from 2.28.0 to 2.31.1. I uninstalled and downgraded back to 2.28.0 but still having the issue. It's odd since normal commits are building without any issue. Is there any difference on how PRs are built?

  1. 1 Posted by Matt on 06 Apr, 2021 05:15 PM

    Matt's Avatar

    Update: It's working.

    I created a new user profile and set the host service to logon with that account and it's now working. Still not sure why normal commits worked but not PRs.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Apr, 2024 04:43 PM
12 Apr, 2024 04:56 PM
11 Apr, 2024 11:16 PM
09 Apr, 2024 10:59 PM
08 Apr, 2024 07:50 AM


06 Apr, 2024 04:06 AM
05 Apr, 2024 01:26 PM
05 Apr, 2024 10:39 AM
04 Apr, 2024 03:41 PM
31 Mar, 2024 05:51 PM
30 Mar, 2024 01:59 PM