Artifacts can't uploaded to Github Release (400 - Bad Request)

erdnussflips93's Avatar

erdnussflips93

11 Sep, 2015 10:34 AM

I configured my appveyor.yml so, that the build is deployed to github.

The Github access token has the scopes: public_repo, repo:status, repo_deployment

The artifacts become packaged successfully, but the upload to github is rejected with "Uploading "WindowsFirewallDashboard.zip" to release assets...Error uploading release asset: 400 - Bad Request".
See: https://ci.appveyor.com/project/ErdnussFlipS/windowsfirewalldashboa...

I don't now why. Can you help please?

Appveyor project: https://ci.appveyor.com/project/ErdnussFlipS/windowsfirewalldashboard
Github project: https://github.com/ErdnussFlipS/WindowsFirewallDashboard
appveyor file: https://github.com/ErdnussFlipS/WindowsFirewallDashboard/blob/appve...

  1. Support Staff 1 Posted by Feodor Fitsner on 12 Sep, 2015 12:03 AM

    Feodor Fitsner's Avatar

    Found the issue. GitHub API has changed slightly - it returns upload URL in a different format.

    We'll deploy AppVeyor update with a fix later this week.

  2. 2 Posted by erdnussflips93 on 12 Sep, 2015 11:31 AM

    erdnussflips93's Avatar

    Great, thanks!

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac