Creating WebDeploy artifact can't find contents of Scripts folder

Eddie Sholl's Avatar

Eddie Sholl

15 Sep, 2015 02:23 PM

Hi there,

I'm trying to build a simple MVC web app, and publish to an Azure web app service. I'm tyring to publish via a Web Deploy artifact. The generation of the artifact is failing because the first file referenced in my csproj can't be found. This is odd, because the same relative file path 'Scripts/angular-animate.js' seems to be found a little earlier on.

The output is available at https://ci.appveyor.com/project/eddiesholl/ang-blog

If I run msbuild /t:package on my local box, all files are successfully found and compressed.

I did find this post, although I'm not sure if this actually helps in my case:
http://help.appveyor.com/discussions/problems/853-adding-files-to-a-web-deploy

I've tried a direct deploy via azure and that build trips up on the same file:
https://azure.microsoft.com/en-us/documentation/articles/web-sites-publish-source-control/?rnd=1#Step75

Any help to understand what I'm missing is much appreciated.

Cheers,

Eddie

  1. Support Staff 1 Posted by Feodor Fitsner on 17 Sep, 2015 03:49 AM

    Feodor Fitsner's Avatar

    It's supposed angular files should be committed to the repo but they are not: https://github.com/eddiesholl/ang-blog/tree/master/ang-blog/Scripts

    angularjs package is "design time" package I don't think it should be restore with nuget restore: https://ci.appveyor.com/project/FeodorFitsner/ang-blog/build/1.0.1#L15

    Hope that helps.

  2. 2 Posted by Eddie Sholl on 17 Sep, 2015 01:38 PM

    Eddie Sholl's Avatar

    Thanks so much for looking into it Feodor. Of course it's so obvious now :) Sorry for taking your time.

    Cheers,

    Eddie

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:59 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac