Cannot discover C++ tests

BigEgg's Avatar

BigEgg

18 Sep, 2015 03:37 AM

I have two build pipeline, one is for C# and one is for C++. Both of them are Visual Studio projects and AppVeyor Test setting is "Automatically discovered".
Here is the links:

C#: https://ci.appveyor.com/project/BigEgg/leetcode

C++: https://ci.appveyor.com/project/BigEgg/leetcode-vu4km

It seem like C# version is working correctly, it can find the tests and run it. However the C++ pipeline, just said: "Discovering tests...OK". How can I let the C++ tests run in AppVeyor?

BTW, the Visual Studio version is 2015, and Environment settings had already been set with that.

  1. Support Staff 1 Posted by Feodor Fitsner on 18 Sep, 2015 03:50 AM

    Feodor Fitsner's Avatar

    That's correct. AppVeyor is able to discover .NET test assemblies only as it's looking for assembly references.

  2. 2 Posted by BigEgg on 18 Sep, 2015 06:49 AM

    BigEgg's Avatar

    So, for C++ tests, I should use Scripts to manually run that, right?

  3. Support Staff 3 Posted by Feodor Fitsner on 18 Sep, 2015 07:05 AM

    Feodor Fitsner's Avatar

    Yep.

  4. 4 Posted by BigEgg on 18 Sep, 2015 07:30 AM

    BigEgg's Avatar

    Got it, thanks

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 01:59 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

17 Jul, 2019 12:16 AM
17 Jul, 2019 12:15 AM
16 Jul, 2019 10:50 PM
16 Jul, 2019 07:47 PM
16 Jul, 2019 06:34 PM

 

16 Jul, 2019 05:17 PM
16 Jul, 2019 10:17 AM
16 Jul, 2019 07:46 AM
15 Jul, 2019 06:33 PM
15 Jul, 2019 06:09 PM
15 Jul, 2019 05:53 PM