Deploying using FTP provider

Sonny's Avatar

Sonny

20 May, 2014 09:58 PM

We're getting a message that 'Neither artifacts nor application were uploaded.' Why isn't it deploying our changeset to our FTP site. Am I missing something?

updating to branch develop
8122 files updated, 0 files merged, 0 files removed, 0 files unresolved
9Discovering tests...Done
10Deploying using FTP provider
11Neither artifacts nor application were uploaded.
12Build success

  1. Support Staff 1 Posted by Feodor Fitsner on 20 May, 2014 10:11 PM

    Feodor Fitsner's Avatar

    Hi Sonny,

    Does the build produce any artifacts?

    - Feodor

  2. 2 Posted by richard on 19 Nov, 2014 03:48 PM

    richard's Avatar

    Hi ,
    Any solution for this, I've the same problem.

    thank you

  3. Support Staff 3 Posted by Feodor Fitsner on 19 Nov, 2014 05:43 PM

    Feodor Fitsner's Avatar

    Hi Richard,

    Do you have any artifacts on Artifacts tab of build details?

  4. 4 Posted by Anthony on 24 Mar, 2015 05:28 PM

    Anthony's Avatar

    Was there any answer to this one, I'm getting the same message. I'm not completely sure on how to set the build artifacts and the locations of them, I think that is what the issue is.

  5. Support Staff 5 Posted by Feodor Fitsner on 24 Mar, 2015 11:15 PM

    Feodor Fitsner's Avatar

    Hi Anthony,

    Take a look at this article about packaging artifacts: http://www.appveyor.com/docs/packaging-artifacts

    -Feodor

  6. 6 Posted by Alexander on 24 Sep, 2015 01:27 PM

    Alexander's Avatar

    I've setup artifacts but FTP deployment just uploads application.zip file. How can I upload application through FTP?

  7. Support Staff 7 Posted by Feodor Fitsner on 24 Sep, 2015 06:25 PM

    Feodor Fitsner's Avatar

    You should specify artifact in application setting, not artifact.

  8. 8 Posted by rajan.bhayana on 26 Nov, 2015 05:10 AM

    rajan.bhayana's Avatar

    i tried this

    I have an asp.net application and it produces an artifact since i have set automated web package.
    Then i copied the name of artifact and pasted in appplication settings under deployment.
    And during deployment i get the error - Application artifact must be a ZIP archive.

  9. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac