Cannot find artifacts, through success

eric.aka.darth_vader's Avatar

eric.aka.darth_vader

06 Oct, 2015 09:32 AM

I cannot package artifacts, under artifacts tab, there is no artifacts listed although:

Packaging artifacts...OK
Build success

I tried dir %APPVEYOR_BUILD_FOLDER%\out as one discussion suggested:

dir %APPVEYOR_BUILD_FOLDER%\out
 Volume in drive C has no label.
 Volume Serial Number is F074-BCDF
 
 Directory of C:\projects\static-program-analyzer
 
File Not Found
Command exited with code 1

But it does not work.

Any ideas?

  1. Support Staff 1 Posted by Feodor Fitsner on 06 Oct, 2015 04:42 PM

    Feodor Fitsner's Avatar

    What folder/files are you trying to push to artifacts? What settings do you use?

  2. 2 Posted by eric.aka.darth_... on 07 Oct, 2015 04:01 AM

    eric.aka.darth_vader's Avatar

    I am just trying to push the entire zip. The whole project folder! The settings that i use is just the project name static-program-analyzer in artifacts

  3. Support Staff 3 Posted by Feodor Fitsner on 07 Oct, 2015 04:02 AM

    Feodor Fitsner's Avatar

    Why would you need that?

    You can use 7z.exe to pack the folder and then push it with script: http://www.appveyor.com/docs/packaging-artifacts

  4. 4 Posted by eric.aka.darth_... on 07 Oct, 2015 04:07 AM

    eric.aka.darth_vader's Avatar

    Thanks for the quick reply! I havnt tried the 7z way though.
    I also tried in artifacts

    subdir\**\*.exe

    to pack the exe as artifacts and that does not work too.

    Okay i will try packing with 7z

  5. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac