AssemblyInfo patching not working

Bilal Fazlani's Avatar

Bilal Fazlani

11 Oct, 2015 09:21 AM

I turned on AssemblyInfo patching for my project.

here is what my assemblyinfo file looks like:

[assembly: AssemblyVersion("3.0.0.0")]
[assembly: AssemblyFileVersion("3.0.0.0")]

This is what the log says:

Patching SampleLogMaker\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext.Common\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext.Common.Testing\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext.Identity\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext.Identity.IntegrationTests\Properties\AssemblyInfo.cs...OK
Patching TrackerEnabledDbContext.IntegrationTests\Properties\AssemblyInfo.cs...OK

But after the build when I go to my repository, and check the AssemblyInfo files, they look the same. Isn't this feature supposed to increase the build version in my source code ?

  1. Support Staff 1 Posted by Feodor Fitsner on 11 Oct, 2015 11:44 PM

    Feodor Fitsner's Avatar

    It patches AssemblyInfo files on build worker machine - it's not supposed to modify your repository.

  2. 2 Posted by bilal fazlani on 12 Oct, 2015 08:50 AM

    bilal fazlani's Avatar

    Okay. thank you.

  3. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac