rdesktop on Linux requires CredSSP

Maarten's Avatar

Maarten

16 Oct, 2015 02:48 AM

I tried to rdp to a worker using the scripts at http://www.appveyor.com/docs/how-to/rdp-to-build-worker .

The output of the rdesktop command (on Linux) is:
Failed to connect, CredSSP required by server.

On Internet, they suggest to untick the option "Allow connections only from computers running Remote Desktop with Network Level Authentification (recommended)".
See https://www.youtube.com/watch?v=fuar6l60_lA

  1. 1 Posted by Maarten on 16 Oct, 2015 02:52 AM

    Maarten's Avatar
  2. 2 Posted by Maarten on 16 Oct, 2015 02:59 AM

    Maarten's Avatar

    Output of xfreerdp:

    [04:58:15:344] [20878:-1963251968] [ERROR][com.freerdp.core] - credssp_recv() error: -1
    [04:58:15:344] [20878:-1963251968] [ERROR][com.freerdp.core] - freerdp_set_last_error 0x20009
    [04:58:15:344] [20878:-1963251968] [ERROR][com.freerdp.core.transport] - Authentication failure, check credentials.If credentials are valid, the NTLMSSP implementation may be to blame.
    [04:58:15:344] [20878:-1963251968] [ERROR][com.freerdp.core.connection] - Error: protocol security negotiation or connection failure

  3. Support Staff 3 Posted by Feodor Fitsner on 16 Oct, 2015 05:14 PM

    Feodor Fitsner's Avatar

    You can easily change that by adding this line to your build script:

    reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp" /v UserAuthentication /t REG_DWORD /d 0 /f
    
  4. 4 Posted by Maarten on 16 Oct, 2015 11:11 PM

    Maarten's Avatar

    Thanks, it works perfect now.
    The connection now uses SSL.

  5. 5 Posted by Denis Trofimov on 01 Jun, 2016 12:40 PM

    Denis Trofimov's Avatar

    NOT a solution, only a (poor) workaround. Turning security down is never a solution and generally only a temporary solution.
    Solution is to use package freerdp, for me worked like piece a cake. @Debian Jessie

  6. 6 Posted by Fábio Rizzi on 22 Jun, 2016 11:21 AM

    Fábio Rizzi's Avatar

    xfreerdp works like a charm.

  7. 7 Posted by Guy Rosinbaum on 28 Jul, 2016 12:09 AM

    Guy Rosinbaum's Avatar

    xfreerdp is not working either . Going from Raspian on a Pi3 to windows 2012 r2 with 25 RD licenses.... Any thought?

  8. 8 Posted by Greg on 22 Dec, 2016 07:28 PM

    Greg's Avatar

    add user (administrator or with added role for remdesk ) to server with the same name as you use in linux (works for me )
    pozdr
    Greg

  9. Ilya Finkelshteyn closed this discussion on 25 Aug, 2018 02:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Jan, 2019 01:59 AM
22 Jan, 2019 12:17 AM
21 Jan, 2019 07:55 PM
21 Jan, 2019 05:55 PM
21 Jan, 2019 05:52 PM