Builds failing: Could not verify the SSL certificate

Victor Balakine's Avatar

Victor Balakine

22 Nov, 2022 01:56 PM

I'm getting this error trying to build on Ruby 2. The cert appears to be valid when I check locally.

Could not verify the SSL certificate for
https://rubygems.org/quick/Marshal.4.8/rspec-3.12.0.gemspec.rz.

https://ci.appveyor.com/project/balakine/tty-screen/build/job/72pawpdubjliagro

  1. Support Staff 1 Posted by Feodor Fitsner on 22 Nov, 2022 04:13 PM

    Feodor Fitsner's Avatar

    Looks like newer Rubygem builds require Ruby 2.3 and above.
    I'm testing with Ruby 2.0 and Rubygem cannot be upgraded to the latest with any method:
    https://ci.appveyor.com/project/FeodorFitsner/tty-screen/builds/454...
    https://ci.appveyor.com/project/FeodorFitsner/tty-screen/builds/454...

  2. Feodor Fitsner closed this discussion on 22 Jan, 2023 09:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

27 Jan, 2023 08:06 PM
27 Jan, 2023 08:05 PM
25 Jan, 2023 03:23 PM
25 Jan, 2023 03:22 PM
23 Jan, 2023 03:29 PM